Page break before folders not working

Since today’s update, the following problem has occurred.

  1. In the Compile dialog, set the “Text and Folder Separator” to Page Break.

  2. Click Compile.

The resulting document does not have a page break before folders.

  1. In the Compile dialog, set the “Text and Folder Separator” to Custom, then type “abc” in the box.

  2. Click Compile.

The resulting document has “abc” before folders.

  1. In the Compile dialog, set the “Text and Folder Separator” to Page Break again.

  2. Click Compile.

The resulting dialog STILL has “abc” before folders.

It seems that the “Text and Folder Separator” option is being ignored and the compilation is always using “Custom” instead.

Thanks for reporting this johnkfulton. Due to some late FDX changes this bug has been introduced. We will provide an update for this as soon as possible.

Just a note to say that 1.5.3 is available with a fix for this, so please use Help > Check for Updates to grab that if you have not already!

Thanks for the quick fix!

After update 1.5.3 I have the following problem:

In the Compile window: When I select ‘Pg Break Before’ for a page and compile my .mobi document a page break is generated but a blank page also appears. Its as if 2 page breaks have been generated.

Yeah, that is an older bug that still hasn’t been fixed. This fix was strictly for the broken Separators code that was initially released yesterday.

Oh thanks Amber, I didn’t realise this was an old issue. I’m sure that this wasn’t happening in the previous version though as I’ve been compiling furiously recently and only experienced this problem today. Do you know where I could download the previous version?

1.2.5 is still available from this page, if you hop down to “older versions”, but there have been so many fixes for ebook compile otherwise that I’d strongly urge you to instead just edit the compiled .epub in Sigil to remove the extraneous page break. It’s caused by an empty paragraph before a paragraph set with a class including “page-break-before: always”; removing the empty line or adjusting the CSS should fix you up. (Double-check of course if you have any other instances of the pbb class that you do want to keep that for!) Sigil is quite friendly to work with and as I said, aside from this issue, the ebook output from 1.5.3 is vastly improved over 1.2.5, including how font size is handled on reading devices–e.g. fonts from 1.2.5 can’t be resized correctly on the new Kindle Paperwhite, but this was updated for 1.5.3.

I downloaded the new version with the bug fix, but I am having additional problems with separators that I didn’t have before version 1.5:

  • The only Text and Folder Separator setting that works is Page Break
  • For Folder and Text Separators only Custom and Page Break work (not Empty Line or Single Return)
  • All Text Separator setting insert what they are meant to, but Custom additionally inserts an empty line before the custom character

Paul

I’ve also found a similar issue after updating to version 1.5.3.

Selecting “Single Return” (in Text Separator, Folder and Text Separator, Text and Folder Separator) results instead in an Empty Line after compiling.

“Page Break” (in Folder Separator) works fine.

I don’t know if this matters but I’ve checked these results by compiling to an RTF file.

I’m sure these are not “older bugs that still haven’t been fixed” but have surfaced in the recent update.

Older versions can always be found on the change log page. Just click the “older” link to go to an older release, and you’ll find a download link beneath the header for the most recent prior version.

Thanks for the reports, guys. I’ve been checking into this for PDF, RTF, and epub samples, and in my testing, the “empty line” separator works as expected for all separator types, adding a single empty line between the items. All the other separators also work in my tests but add an additional empty line which shouldn’t be there. If this isn’t the same as what you’re seeing, could you provide reproducible steps for the problem? I want to make sure I haven’t missed something as I’m making a high-priority report on this so we can get it fixed as soon as possible. Thanks!

(Note, this is separate from the additional page due to “page break before”, though sort of compounded with it; that one is already on our list, as Ioa said.)

I’m finding that in my set up I am not getting an empty line where there is a folder separation (after the First Page Header as shown in the structure below) where I did with the previous version. I have tried compiling as RTF and Word with the same results.

I have been using the following compile settings:

  • Text separator: Custom or Empty Line
  • Folder separator: Empty Line
  • Folder and Text Separator: Empty Line
  • Text and Folder Separator: Empty Line

The structure in the binder is:

  • Short Story
    [list][*]Document: First Page Header
  • Folder: Story (no text content)
    [list][*]Document: Scene 1
  • Document: Scene 2
  • Document: Scene 3
    [/:m][/list:u][/:m][/list:u]

The document First Page Header is set to compile “As is”. When that setting is turned off an empty line is added. I can see that this might be a deliberate alteration, but it is a change in behaviour from the previous version and therefore worth checking.

Paul

Yes, that (an additional empty line which shouldn’t be there) is exactly what I’m getting when I compile to RTF using “Single Return” (in Text Separator, Folder and Text Separator, Text and Folder Separator). So, from my part, I can confirm it.

Thanks, Paul. “As-is” shouldn’t affect the separator here, so that’s a good catch; it’s likely due to the code change that’s producing the additional empty line at the end of documents prior to the separator.

alexandremaki, thanks for the confirmation!