"Page Break Before" sometimes adding blank pages

I’m having trouble figuring out where these blank (except for header/footer) pages are coming from.

I have a book with parts (folders), divided into chapters (folders), divided into scenes (documents with body text). The blank pages seem to only come after the front matter and after the “part” pages. (My aim is to have a single page that says only “Part 1”, then on the next page, a “Chapter 1” title, and the text of the following scene documents.)

The Chapter folders are working as expected - they start on a new page with the text of next scene document below it. But the front matter and the Parts folders both create blank pages after them.

I’ve set all of the separators to “single return”, except for the document-to-document text separator, which is “↵ • • • ↵”. (That’s working fine).

In the contents list, I’ve checked the “pg break before” box for the Parts folders and Chapters folders. If I uncheck these, there are no page breaks at all, and the headings all come one after another on the same page.

Here’s the output I get:

Front Matter
Blank page
Part 1 Title Page (looks good)
Blank page
Chapter 1 heading and text, with text documents separated by “• • •” with line breaks before and after (looks good)
Chapter 2 (looks good)
Chapter 3 (looks good)
Part 2 Title Page (looks good)
Blank page
Chapter 4 (looks good)

I can’t figure this out - the “page break before” each new chapter works fine when it follows a chapter, but it gives me an extra page when it follows a Part folder. And the page break before the Part title page looks fine when it follows a text document, but when it follows the front matter it makes a blank page.

I bet there’s a simple answer but I’ve been trying all kinds of settings for a while now and I haven’t found it.

Oh, and the page numbering starts on the first blank page, which suggests to me that it’s not part of the front matter somehow extending down, but part of the following “Part 1” section.

The first thing to check here is the “Always start section on” setting under Section Layouts > New Pages in Compile. If your chapters or parts are set to always start on a recto page, then a blank page may be inserted to ensure this.

The page numbering shouldn’t start on a blank page, though.

All the best,