page break issue when opening a compiled draft with Pages

So I just recently switched from using MS Word to using Pages as my main word processor. One problem I’ve noticed is that when I run “Compile Draft” from Scrivener to create an RTF document and try to open it with Pages --> I lose all the page breaks (between chapters) and I lose all the footer information. When I open this same document with Word, the page breaks and footers look fine. Is there a compatibility issue with Pages? I’ve tried a few different export formats without any luck… Thanks for any info! ~y

Yup, that’s a problem with Page’s RTF importer, it is notoriously weak in terms of what features are supported. You’ll have much better luck going to Word with an RTF out of Scrivener, saving that as DOC file, and then opening it in Pages.


Yes, I’m afraid Pages doesn’t ready RTF very well - it strips page breaks, images, footnotes, headers and footers and more. The best way of getting documents into Pages is to save as RTF and then use Word as an intermediary step to save as DOCX or DOC, and open those in Pages (as Scrivener’s DOC and DOCX export aren’t great).

All the best,

P.S. As always, AmberV beat me to the punch. :slight_smile:

OpenOffice or NeoOffice (which I prefer) work as well as intermediate. For those who prefer free solutions.

This may be the wrong place to mention this, but I’m having the same prob with Word. I save as rtf, open and page breaks are gone. I’ve had to do them manually every time I compile, and I have a couple of very long, multi-chaptered projects. I’m using Word for the Mac 2008.

Page breaks definitely work when exporting from RTF to Word 2008, so it must be something to do with your settings. How are you adding the page breaks?
All the best,

There’s a place on the compilation menu for page breaks. But I must be doing that wrong.

When a folder (ex: 3) is followed by its document (ex: Chapter Three), are both supposed to be clicked for compilation, or only the actual document, skipping the folder? I am skipping the folders and clicking the documents themselves (one doc for each chapter).

However, I notice now that for some reason (not sure why) I have included the page break on the folder line, not the doc line, and since I’m skipping the folders… I guess I’m also skipping the page breaks.

By default folders have page breaks turned on as a bit of a convenience—most people use them to break apart larger sections of the book. If you are excluding folders then their page breaks won’t be added to the compilation—I think—that one is hard to verify for me because I don’t have a word processor on hand that handles RTF page breaks.

Okay yes, my assumption was correct, I just got it working in Mellel. If folders are turned off then their page breaks will not emit into the compilation. As I was going to say initially, if you need folders to be “silent” just make sure all of the checkboxes for the folder column in the lower-left matrix of the first tab are unchecked.