page breaks between para's when I compile

When I type new text directly into Scrivener (as opposed to pasting text in from Word) and then compile for Word, each paragraph is on its own page. I have unticked everywhere that has ‘insert page break’ and I still have the problem.
Anyone have any suggestions?

Try turning on invisible characters in the Format/Options menu. It sounds like you might have page break characters floating around in the text that got pasted in from Word. You should see a blue line across the screen wherever they appear. You can just backspace over them like any other character to delete them.

Thank you. When I turn on the invisible characters, all I see at the end of each paragraph is the little paragraph symbol. Other ideas?

Just so we’re clear, you’re seeing page breaks that are falling between paragraphs within a single document in the binder? Or do you have your draft broken down so that each binder item is a paragraph? If it’s the latter, and the page breaks are between complete items, it may just be that you need to change a setting in the Separators tab of File > Compile to insert a single return instead of a page break between text documents.

It’s the former. page breaks between paragraphs in a single document.

You can probably ignore everything before the dotted line, below. I was mistakenly under the impression this was pasted text not typed in text and this experiment probably won’t be of any use to solving the problem.

Since this is just text you’ve typed in, and we’re definitely looking at multiple paragraphs in a single item in the binder, in a single document, some more details about your compile settings would be useful. Did you start with a template, or a blank project, and what format are you using to compile to (as in, Word .docx, RTF, HTML, etc)?


Here is an experiment to try:

  1. Select one of the sections that is misbehaving, in the binder, and press Ctrl-5 to take a snapshot backup of it, and verify there is a backup in the snapshot list Documents/Snapshots/Show Snapshots. If our experiment messes up your formatting badly, we can return to it afterwards
  2. Now in the main text editor, select all of the text with Ctrl-A and then copy it
  3. Delete the text
  4. Select another binder document and then come back to this one (just to make sure the data file gets reset to empty)
  5. Put the cursor in the editor and use Edit/Paste and Match Style

Now try compiling again and see if that section works. If you had italic ranges, or other formatting in the section it will have been lost in this procedure. It cleans out all formatting, and hopefully whatever weirdness came in from the original Word paste. So you’d need to use the snapshot as a guide to restore formatting.

If it didn’t solve the problem, then just go ahead and use the “Roll Back” button in the snapshot list to restore the original text.

It looks like OP is having the issue with text written IN Scrivener, NOT pasted from Word.

(Thanks, I missed that!)