Page breaks on compile seem to be getting lost

I searched through the forum, and I didn’t see this same difficulty.

I am writing a book with chapters in which each chapter is a separate, single text document (as opposed to a folder or a composite of difference scenes).

I have a custom compile setting which is based on the Manuscript preset, but have deflagged plain text transformations, and have removed leading spaces. I have one As-is title page. In the compile contents setting, each document has “Page break before” checked. I compile to .rtf format.

When I open the .rtf document in TextEdit, there are no page breaks between chapters. Opening the same .rtf document in Office 2011, the page breaks are present. But if I print to .pdf from Word (my editor wants a .doc and a .pdf), the page breaks are once again lost in the translation.

It’s my suspicion that this is a Mac OSX issue; I’m using 10.8.3 and Scrivener 2.4.1. I’ve spent a few hours fiddling with this, but nothing I do seems to make a difference - and this is not a problem I’ve had prior to this, and I’ve used Scrivener for, I think, the past 10 novels.

Help?

ETA: Printing to .pdf from the same .doc file on a PC preserves the page breaks.

TextEdit isn’t the best tool for checking the quality of RTF files. It only supports a relatively small subset of the format. That said, you should see page breaks, but you need to have TextEdit in “Wrap to Page” mode, in the Format menu. Maybe the mode got flipped accidentally?

As to the problem with Word for the Mac and its PDF generation, I don’t know what to tell you there. I’m more familiar with the PC version of Word.

Can you not make the PDF using Scrivener? It seems to me it would be easier to just compile to PDF and .doc/x.

The preference in Text Edit is set to wrap-to-page.

But even with that preference setting, when I compile a completely new .rtf, TextEdit doesn’t recognize page breaks that exist between chapters. While the page breaks exist if I open the .rtf document in Word 2011, the same document doesn’t recognize page breaks if I print to .pdf from Word. I haven’t opened the .rtf file in Word on the PC, so I can’t say if it’s a problem with TextEdit on the Mac - but I have to think the print to .pdf option’s missing page breaks that are clearly there in the .rtf in word has to be more than a coincidence.

The page breaks do exist if I compile to .pdf, which is helpful (so thanks for that - I’ve always just used the print to .pdf from whichever other document I’m in at the moment, since - until now - that’s always worked well.)

Perhaps, the only thing is, I can’t think of anything that has changed in years, in this regard, and while I’m not testing from the Mac version of Word, I do have TextEdit and it’s showing me page breaks just fine. I set up a quick test to emulate your settings by putting a title page with “as-is” then five regular text files after it all on the same level. I then checked off “Page Break Before” for each in Contents, compiled and got page breaks in TextEdit.

(Incidentally, you can generate page breaks automatically rather than with checkboxes. It’s of no concern right now since you already have it that way, but for future reference the Separators pane lets you do so. You could set the Text/Text separator to be page break and forgo having to mess with all of the individual switches.)

Here is a quick test of the system:

  1. Create a new temporary project using the basic Novel template (just put it somewhere like Desktop, you can delete it once the test is complete). We’ll just use a template because it has some example material set up that we can use to quickly compile with.
  2. Select the folder called “Chapter” in the Binder.
  3. Hit Cmd-D three times so you have four of these folders with one empty file in them.
  4. Use [b]File/Compile...[/b] and set the export format to RTF.
  5. Click Compile and open the RTF in TextEdit with Wrap to Page mode on.

You should have five pages. Four for the four chapter folders, and the fifth for the title page. This doesn’t test your precise setup, but that’s rather the point. If this prints fine out of Word and looks good in TextEdit, then we know something is up with the project settings.

I’ll toss in that opening a generated RTF with Abiword (Linux) also seems to loose the page breaks… The PDF version is fine.

I know Linux isn’t supported, etc., just wanted to add a data point in case it helps somebody.

Bruce

Well, Abiword is multi-platform and seems to get as much Windows love lately as Linux, so no worries. In my testing Abiword appears to have difficulties with the RTFs that Scrivener creates. From the Mac version, they caused Abiword to behave erratically and crash a lot, and from Windows the RTF did not have page breaks as you noted, and I saw some other formatting errors in addition to that. I had much better success with ODT from both platforms.

Scrivener can compile to Word and PDF, as your editor wants. Why compile to RTF? (Why not persuade your editor to use Scrivener, or choose an editor who already does?)

Out of curiosity…if you open the RTF in Pages, are the page breaks preserved?

Scrivener’s native format is RTF, so compiling to it will be fastest and most error free since there are no conversion layers in between the compiler and the ultimate output. Meanwhile Word can load an RTF file as well as it can a DOC file, so there really is no negative to using it.

But in cases where the word processor does a poor job of reading RTF, there are indeed other solutions. Pages in fact is one of those, I wouldn’t recommend using it to test any RTF files—and page breaks is specifically one of the features it silently drops from the file loading.

Indeed—but if the OP is having problems with RTF for whatever reason, isn’t it worth trying Word and PDF direct? Or if a problem exists with RTF will it also occur with Word come what may? Also thought that if the problem is specific to the OP’s Mac, then it might be worth a punt to try other options. Things sometimes work for quirky almost inexplicable and illogical reasons.

Still think the OP should get their editor to invest in Scrivener. :smiley:

In regards to the original issue, they stated the file works fine in Office, so I suspect it’s just a viewing problem on their system with TextEdit. It wouldn’t hurt anything to use DOC/X or PDF, it probably wouldn’t change anything either. Both of these formats are derived from the RTF. So if there really is a flaw with the RTF, switching to a lower domino in the chain won’t fix it. I don’t think there is anything wrong with the RTF though.

For the second issue the editor itself is at fault. Abiword cannot correctly import an RTF file (and DOCX/PDF wouldn’t help here), so I recommend ODT instead of one wishes to work with Abiword as a post-processing tool.

There is that. :slight_smile:

As the person with the Abiword comment, thanks so much for reminding me of ODT/LibreOffice (I use Libre)… why I didn’t think to use it, but my system was set that double-clicking defaulted to Abiword. Duh.

Anyway, Libre displays the page breaks correctly, and also shows annotations to the side as “Word style” comments, which is really nice.

So, this issue led me to a great discovery :slight_smile:

Thanks!

Bruce

Great! Yeah, LibreOffice and most of the OpenOffice forks are good editors when paired with Scrivener.

Thanks for that explanation…appreciated. Helps me to understand Scrivener in a little more depth.