Page number appears on 1 of 6 Blank Docs in 109p. manuscript

I mastered the header/footer page number settings, and everything in my .pdf looks as I want it to, until I reach the last two pages of my doc. Blank Page 108 has a page number printed (compiled from a blank doc in the manuscript, the only blank doc out of 6 in the manu that managed to get a # in the footer) and Page 109, which is my Acknowledgements text, has no page number. I’ve double, tripled checked that the settings on these two docs match the others in the manu and they do. I tried deleting and adding a new blank doc before the Acks., I’ve tried moving a blank doc that works elsewhere in the manu, but those two pages still compile with the wrong footer.

These two pages also behave this way when printed.

“No header on first page and pages following page breaks” : Checked.
“No header or footer on single pages” : Checked.
“Different first pages header/footer” : Checked.

I’m not getting any errors, or seeing anything in my system log that indicates a hiccup.

I’m on a MacBookPro, Snow Leopard OS X (10.6.8), Scrivener 2.1.

Anybody have a similar issue? Any suggestions, workarounds? I’m so frustrated! Thanks in advance!

(On a happy note, I quickly and easily exported to .mobi and .epub yesterday. Fabulous)

Hello,

Could you please post screenshots of all three panes of the header/footer tab view (first page, facing pages etc)? And also please show screenshots (blurred to hide text if you like) of the documents in the project that aren’t appearing as you want, and maybe of the PDF pages too. (Compile is very flexible so it’s difficult to guess what the cause is without more information.) Have you got “No header and footer on single pages” ticked? Is this blank page definitely a single page not attached to anything else in its document? Have you got different settings for facing pages?

All the best,
Keith

Thank you for your response!

I have realized that my Acknowledgements page is a single doc, and therefore won’t be numbered (red face). But the blank, single page doc before it still compiles with a page number.

I do have “no header and footer on single pages” ticked. As far as I can tell, the blank page is definitely a single page not attached to anything else in the document. And I do have different settings for facing pages.

I am attaching more screenshots than you could possibly want, so that you can see pages that work as I want them too.



More screenshots…



And more screenshots (never needed to take any before, so I apologize for them being so large). The first one shows an example of how the other blank pages in the doc compiled correctly. The second is the rogue blank page with a number in the footer.

I appreciate your help and patience.

Thank you.


Hi,

Sorry for the late reply - I’ve just got back from a long half-term weekend with the family.

Looking at the screenshots, it seems to me that the page before the acknowledgements is not actually blank. There are two return characters there, as you can see from the blue invisible markers. To achieve a blank page, you should use the tag <$BLANK_PAGE> with nothing else in the document. If this isn’t present and the document contains returns, spaces or whatever, then it won’t be treated as truly “blank”.

Hmm, but that isn’t the real issue. Having just tested a similar set-up to you but using <$BLANK_PAGE>, I am seeing the same problem, so there may well be a bug here. I’ll look into it this week and let you know what I find - if it’s a bug I’ll fix it for 2.2, which will be out very shortly.

Thanks!

All the best,
Keith

Hi,

Please try this build:

literatureandlatte.com/dlbet … orBagn.zip

There were two bugs:

  1. Headers and footers would only be omitted from single pages if the settings were also set up to omit headers and footers after a page break.

  2. If the last page was a single page, then the last-but-one page would not be treated as a single page even if it was one. I believe this was the issue affecting you.

Both should be fixed in the build linked above.

Thanks,
Keith