Page number has gray background color

Hi there,

I’m trying to compile based on specific submission requirements like this:

Upper left corner: title / author Upper right corner: page number

So what I have done is insert this in the Header on the compile screen.
<$fullname> / <$projecttitle> (spaces inserted to push page number into position) <$p>

It works except the page number is black text on a gray background.

Any idea how to remove the background color from the page number?
Am I constructing the Header correctly?
Google has failed me.

The construction looks fine, if you’re willing to fake the placement, since Scrivener’s settings don’t currently allow you to split the header for right and left alignment the way you need. You might prefer to place it all on the left side, then add a tab and right tab stop for the header in your word processor after compiling to align the page number accurately.

Scrivener doesn’t offer text or background colouring for the header or footer, and given you’re only seeing this on the page number, my guess is that you have field shading turned on in whatever word processor you’re using to view the compiled document. The page number is a dynamic element rather than static text like the rest of it, so is indicated as a special field by the shading. In Word this setting is controlled under File > Options > Advanced, under the “Show document content” section.

that was it… it was Word doing it.

thank you :slight_smile: