Page numbering/printing

Page numbering: I want to print a chapter from the middle of a manuscript for proofing. But it prints with page numbering starting from (1) instead of following the sequence in the manescript (eg.157) Anyone able to help me print but with page numbers that are in the manuscriipt sequence?

== Miserable answer graciously censored by its own author. ==

This is what the option to “treat compile group as complete manuscript” is for. See Section 23.4.1 in the manual. (To be clear, this option should not be checked.)

1 Like

@kewms That is incredibly convenient. I have to say that if I knew about it, I managed to completely forget. (I pretty much never select what to compile from the panel itself. I rather use “current selection”.)

But… why is it not offered for individual documents ? Why only parent documents ?

Seems to me that this could be useful even when compiling from “current selection”. Multiple documents being selected (sequential/consecutive or not) or just a single one…

Practical example :
When I am done with the composition and editing phase of a novel, I work it furthermore on a print-out version.
And when a chapter or sub-chapter is filled with scratch-offs, arrows and hand written replacements, I like to apply those to my original document and reprint.
Would be then nice to have the page numbers (or whatever relative placeholder used) match their position to the whole, even though I ended up compiling/reprinting a single document. Chapter or sub-chapter.
→ As it is now, my workaround is that I have the documents’ title set to print at the top of my pages, and I number my documents by hand, in their title, in the binder. So, in the printed version of my draft, I eventually end up, after a reprint, with chapter 1 page 1,2,3… chapter 1.5 page 1,2,3… chapter 2 page 1,2,3… etc etc.
image
At least, doing that, there is no confusion as to what goes where.
. . . . . . . . . . . . . . . . . . . . . . . .

If I understand properly, as it is at the moment, whishing to reprint a single document, I would have to place it into its own otherwise empty container document/folder in the binder ? Or give it a dummy child document ? (A document that is not parent to another is not available in the list – and accessible only if child of another one itself (But I dislike selecting it this way, since it messes up included/excluded from compile…).)
Or convert every single document to folder ?
Isn’t that kind of overcrowding the binder just to have access to a function ? (Not to mention how, having all documents be folders, would void other useful features…)

P.S. About a multiple selection of non-consecutive documents, I wouldn’t mind, if that makes it complicated or impossible to offer the function, to compile/reprint these non-sequential documents one at a time.

I will definitely add that to the wishlist.
But it would be nice if someone could provide a few clarifications.
Or explain why it is as it is…

Here I am doing it for one chapter. There’s another book before it in the Binder, so it comes out as chapter 98.

I see, but in your case (having more than one book inside a single Scrivener project), unless I am wrong, that won’t work any which way. (?)
So that doesn’t really explain why it is as it is. (?)
(Were you to compile the whole draft, you’d still end up with a “chapter 98”. You are missing the reset placeholder.) (?)

No. There is no reset placeholder, and if I compile the second book, that is chapter 1.

(It’s actually the first book, but I moved it after the 2nd to test this feature.)

Compile your draft like that (book2 / book 1), you’ll get this chapter as “chapter 98”…

Just like I said, you are missing the reset between the 2.
Because your reset is positioned for Book 1 / Book 2.

Here’s the usual way of compiling it (without moving anything around). (It comes out as chapter one.)

Of course, since it is the first chapter of your project.
You are mixing things up…

No. It’s the 98th chapter in the project. It’s the 1st chapter in the book. I compile one way to get “chapter one” and the other way to get “chapter ninety-eight”.

Yes but you have the “treat compile group as complete manuscript” checked…

The expected behavior is
“treat compile group as complete manuscript” checked = compile group is numbered as Chapter 1.
unchecked = compile group is numbered as Chapter 98.

Is that what you’re seeing, @drmajorbob ?

Yes. I now perceive that @Vincent_Vincent wants a way to compile only the 2nd chapter and have it compile as chapter 2. But I lost the thread and don’t have an answer.

Not your fault @drmajorbob , as there is no answer at the moment.

That, we already have.
My wish is to be able to do it

  1. even if the chapter is a single non-child / non-parent / non-folder document. (In other words, a self-sustained chapter. Which, at the moment, is simply impossible to select for the compile in a fashion that allows the feature to be used.)
  2. much better : using “current selection” in the compile panel. (So the user doesn’t have to modify the include/exclude from compile state of sibling documents. → [EDIT] Which, I just figured, would fault the feature anyways, should one or more sibling be located earlier in the draft than the target document. For e.g. : compiling a subchapter, that subchapter document would move up in the documents’ sequence, taking the place of previous documents temporarily excluded from compile, therefore inheriting the <$sn> value of the topmost of those. [END OF EDIT] )

Meanwhile, if, on the other hand, someone knows a reason why having this feature made available for a compile based on “current selection” couldn’t work, I’d like to know.

I don’t know the answer, but I’ve added the “wish list” tag to this thread.

I like the sound of this (I have no idea what’s going on in the rest of this thread), but when I “Compile” I’m not offered “treat compile group as complete manuscript”. It’s not in my compile window. Any idea why that would be?
And, if you don’t mind me asking, why shouldn’t it be checked?

The option will only be available if you’ve selected a sub-folder in the Contents dropdown menu.

If it is unchecked, the selected group will not be treated as the complete manuscript, and therefore will be numbered according to its location in the overall manuscript. See Section 23.4.1 in the (Mac) manual for more information.

If your project consists of a single long manuscript, you probably want to uncheck the option. If your project consists of several related short manuscripts, such as articles or short stories, you probably want to check it.