page numbers cut off

Hello, I hope someone can help…

I am using Scrivener 1.055b…and suddenly my page numbers have disappeared when I try to print.

Usually, I print drafts (I do not EXPORT them…yet) directly from Scrivener, and on the top right hand corner, there is always the name, date, time, and page number. After I upgraded to the beta, the page number is cut off, only the “/” appears after the filename, date, time.

I have tried adjusting the width of the paper, but I don’t think it is a question of the margins of the body…I can’t find where to adjust the margins of the header. Any ideas? thanks in advance…Richard

Good catch, looks like it might be a bug in the beta. By the way, the settings for regular non-export printing are located in Page Setup (Shift-Command-P). When the box comes up, select “Scrivener” from the Settings drop-down.

In the menu “File”, there is the Option “Export Manuscript…” There you find a section “Text Options”, where you can define your draft header. I’d try this first.

Note that in the new beta, there are two separate options in Page Layout, one for the page header, and one for page numbers - make sure that both are selected.

Also note that the new beta uses OS X’s standard header methods, which the previous versions did not. Some users have reported page numbers getting cut off the edge of the page (though I cannot reproduce this), and on checking have found that the same happens in TextEdit. So, if you do have everything set properly in the Page Layout options, could you then check to see if nothing gets cut off when you try to use TextEdit (which uses the same header system)?

I certainly do not think this is a beta issue, as AmberV suggests.

Thanks,
Keith

Keith, I must be missing something here. What I see in the 1.055b version of the Page Layout settings are:

Printing Options:

  • Print page numbers
  • Print file name/date
    …and so on.

On the right side is Content, which doesn’t have anything to do with headers.

With both file name/date and page numbers selected, I do a print preview and get the filename and date and then a / and nothing, just as described in the original post. I experimented with the scale to page option as opposed to actual size and this made no difference. So as you can see headers are being printed, just not the number. If I remove the filename and date option, I get nothing at the top.

Again, I see no option anywhere in any of these tabs for enabling headers. Just to clarify, we are discussion the main Page Settings, and not the Text Options tab in Export Draft. Perhaps the public beta differs from the version you are running?

Sorry, that is what I mean - print file name/date, not header. Have you tried looking at the header printed in TextEdit, as I suggested? Does the full header get printed there? Everything works fine for me, and I am wondering if this is a problem with Letter format (given that in the UK we use A4). Several users have reported something similar but I have never been able to reproduce it, and some have found the same thing happening in TextEdit…
Best,
Keith

I have this same issue. Filename and time gets printed fine, but everything after the slash is cut off.

Not sure what you mean by recreating it in TextEdit since for me TextEdit prints the page numbers at the bottom right of the page, not in the header (and I don’t know how to get them to print in the header in TE).

Scrivener 1.055b, Intel Mac Mini, 10.4.10… do you need any other info? Oh, yes, I’m using letter size paper.

I just mean does anything get cut off in TextEdit. Honestly, Scrivener is using the standard Apple methods for this, and it is entirely Apple NSView code that determines where the header gets placed on the page. All Scrivener does is tell Apple’s standard printing view what text to print, not where to put it.
Best,
Keith

[b]

[quote=“KB”]
I just mean does anything get cut off in TextEdit. [/b]

Nope! I’d zapped you a file re: this same issue. This is exactly what I’m experiencing. Everything is set correctly–I have quadruple checked–and I even made sure I had the latest printer driver & reset my Scrivener preferences as someone else suggested. Still can’t get the page number to print after the slash. I never experienced this problem with the previous (latest for-sale) version. FWIW, I’m having the same issue on my iMac 24 & MacBook. Both computers were bought this spring if that makes a difference. TextEdit prints everything fine–in fact that’s how I’ve been getting around the page # issue since we emailed. I just copy my current chapter/scene & drop it in TextEdit–TE brings it up & I print. Pages numbers print perfectly from there. But it’s a pain. Other than this one issue, this is truly the coolest software I’ve written in.

~~Candace

I was able to replicate in Scrivener.

Nothing seems to be cut off in TextEdit.

One other piece of information:
If you uncompress the pdf created via Scrivener (using PDFTK, “pdftk file.pdf output file-uncompressed.pdf uncompress”), you will see that (/) is the last character element in the PDF stream. Unless something really counter-intuitive is happening here, the page number itself is not getting inserted in the representation that is getting sent to the PDF writer.

Bryce

Ditto what everyone else is saying. TextEdit is not a problem. I’ve tried using A4 as the paper setting, making sure to set it to printer agnostic, and I get the same ‘/’ and then nothing problem. In fact, I even used a 3x5 card page layout size and it does the same exact thing, its just that the name and date take up nearly the entire card, then a slash and nothing. By the way, Letter is actually a little wider than A4, but shorter. I even tried it with the gargantuan Super B/A3 paper setting and got the same deal. Same with landscape instead of portrait.

It really doesn’t seem to be a case of cropping due to paper size.

Oops… Just replicated it. Will look into it. :blush:
Best,
Keith

Keith,

I’m one of the presumably many who for months have had page number cut off in both Scrivener and TextEdit (when printing directly, not on export).

Maybe the problem you found will fix our problem as well, but am not certain it will. If not, I wonder if you would consider a work around so that we can get pages numbers? I know this is a generic OS X problem, but it would be nice if Scrivener did not rely on something that is broken just because it is the “official” way to do things.

Thank you.

Currently the best work-around for this is to use the Export Draft feature, set headers on, and include the page number in the export (this is all in the Text Options tab of the exporter). If all you need is a part of the draft, you can use the folder scope tool at the top of the Content tab section. Then open this RTF in a word processor that can understand headers and print from there.

Not an easy work-around for a quick print, I understand, but if you really need page numbers, it is at least possible.

Any update on this issue? Thanks, Richard

It was a bug and is fixed for the next update, which will be out at some point over the summer.
Best,
Keith

Just downloaded the 1.07b & my page numbers are printing again–thanks, Keith!!

~~Candace

Phew!

fixed in this update! Thanks Keith! Page numbers are back!

richard