Page outside of group compiles

Not sure this is a bug or just an oddity that I haven’t figured out. When compiling a section of the draft selected from the top dropdown menu of the compile contents pane, if I have the formatting set so that nothing will be included (no boxes checked, no prefixes, etc.) and do not check “ignore levels outside current compile group” in the processing options, I expect nothing to compile–just a blank document with the <<< >>> end-of-text mark if that’s left in.

What happens is that any documents situated before the compile section that are marked “include in compile” and “compile as-is” will compile, even though they do not appear in the contents pane. They don’t compile if the formatting options are set to include any text–even just adding a title prefix to any included doc will result in the expected compile (that is, you can still leave the text boxes unchecked and compile simply the prefix). Nor do they compile if in the binder they come after the compile section.

The Novel template makes this easy to reproduce since it’s set up that way, but it can be reproduced elsewhere.

  1. Using a new project from the Novel template, choose to compile only the first “Chapter” folder
  2. In compile:formatting, deselect all check boxes and remove all title prefixes/suffixes (folder level one and document level one)
  3. Leave the “ignore levels outside current compile group” in processing optinos unchecked
  4. Compile to .rtf

The title page will compile.

Is that what’s supposed to happen? I realize it’s a really odd case and probably not likely to happen intentionally, but it is possible to accidentally mark nothing for inclusion if you get the formatting levels wrong, and having a page appear out of the blue seems confusing.

Sounds like it’s getting confused. When you deselect “Ignore levels outside current compile group”, all the documents preceding the first one chosen in the contents get compiled but then deleted before the final document is created. When there’s no text, obviously something odd is happening there. Added to the list for investigation, thanks.