Page settings/page setup doesn't save correctly

I’m honestly trying not to hate the whole compile process in Scrivener 3, but it’s next to impossible. I have a project that’s fully layouted and everything. All I want to do is to compile it for print in 6x9 novel format. I have a project format saved, and I keep saving the 6x9 paper format to it, but it keeps reverting back to “default” US letter (which isn’t even default on my German machine, but that’s another story). 123 pages on US Letter format

So I enter “edit format” - page settings

  • US letter is shown next to page setup
  • I click on Page Setup and change US Letter to 6x9 novel format and click OK
  • it now shows 6x9 novel next to page setup
    I click “Test” - nothing has changed. The length is still 123 pages.
    I double-check page settings - it’s still on 6x9 novel format.
    I click Save - I try to compile, yet it’s still on US Letter format and 123 pages.

So my question is: How in the world do I get Scrivener to actually save the page setup, even when it’s a non-standard one?

I tried the project page settings option as well, and it doesn’t work either.

This should be a standard feature (to save these options). Is this a bug? And if so, how do I get rid of it?

Thanks,
GTF

So I went back and changed the size of the 6x9 just to see what happens, but now it won’t even recognize the print format at all and compiles to all of 1 empty page.

I don’t even understand where you are trying to do this. Where in the Compile window are you finding this?

And what do you mean by saying that you have “a project that’s fully layouted and everything”. How do you fix the layout before compiling?

You need to explain step by step and if you include screen dumps that would help.

When I look in Compile there is a format called Paperback (6" x 9") at the bottom of the left column; if I double-click on it, it asks me if I want to duplicate and edit; answer yes and I get the Paperback (6" x 9") Copy you see at the top. Isn’t that where you are looking?