Page Size in Scrivener?

I am attempting to import some genealogical trees into Scrivener.

They are currently in Word XP, on landscape, legal “paper,” in Courier 8.

I used the import function, and it imported just fine, except that Scrivener apparently doesn’t believe in landscape formatting, and wraps a number of the lines around, making them unreadable.

I marked the whole page, and went up to the formatting bar, made sure it was Courier 8, and then changed my line lengths to 14". No change. Still wrapped, still showing a real mess.

Tried full page view. Doesn’t help. There does not appear to be a way to scroll sideways so this can be on “one” page.

I have tried printing this to PDF and importing it, but it’s unreadable, too small.

Suggestions?

The editor in Scrivener does not use page metrics at all, so there will be no margins, paper size settings, or orientation display. What happens is the text is imported, and the formatting is converted to the internal format (RTF). Page settings are not applicable until you compile it out again. When you do compile, you’ll find a “Page Settings” compile option pane where you can select paper size, orientation and set margins, as well as adjust headers and footers.

As for the wrapping you describe, I suppose if the document was designed to be laid out really wide, with tab stops and such, that could pose problems. 14" is a bit wider than what the editor will in most cases be displaying at, but since the text wraps to the width of the editor window, depending on how large your screen is, you should be able to get a roughly “landscape” looking document.

I suppose a key thing to point out is that for the most part the Scrivener editor is focussed on the task of writing text, rather than laying it out. This is ordinarily not a problem, but if you’ve got material you started with that is highly designed, it may be a bit rough importing it in. PDF might be a better bet for something that doesn’t need to be edited. Note you can zoom in on a PDF if it is too small. 8pt courier is pretty tiny on my screen.

I have, as I think I said, tried to print as a PDF. CutePDF won’t do it – it takes the middle of the page and does that as the PDF file, and does not do the entire page. Nor can I read the dratted thing.

If there’s another (free) PDF printer driver that doesn’t do this, I can try it.

I used Courier 8 because I needed a mono-spaced font to get the information to line up WITHOUT the use of tabs. (Yes, I know tabs are usually preferred, but to get this to come out, I had to do without them.)

I also had to use a small font in order to fit everything on a theoretically legal sheet of paper turned side-ways.

I can, of course, continue to have Word open, and look at the file there, but part of the potential usefulness of Scrivener is to have my references, especially ones that I use a bunch, in the project, where accessing them is a matter of a single click, not having multiple programs open.

I understand that everything gets converted to RTF, but it puzzles me as to why, if the page is larger than the screen view horizontally, there isn’t a slide arrow for width, as well as one for the vertical length.

I also had a longish Word.doc with an extensive table in it explode the conversion engine, and it did not convert the entire document, but that’s not part of this.

All right, I think I misunderstood part of the problem. It definitely does sound to me as though PDF is the best solution, given the formatting of the document, but the PDF generator you are using does not handle landscape and so is just creating a cropped version of the PDF down the middle of the page—Scrivener is then dutifully showing that cropped version which is of no use. I misinterpreted “too small” to mean the font was too small to see.

If you have a good landscape PDF, it should be no problem once you get it into Scrivener. I’ve tested various landscape PDFs just a minute ago to verify this and it works well. The default is to size to width, so it will zoom out and the entire page width is visible. However you can click that off, view at 100%, and use the horizontal scroll to view the full page (if the editor is not wide enough).

So it sounds like the trick is getting a good landscaped PDF out of the .doc file. I take it you do not have Microsoft Word, then? Because that would seem to me the best way to do it. Just open the .doc file in Word and File/Save As… selecting PDF as the output format? I tried this on an A4 page landscape and it worked fine, and displays well in Scrivener. If you do not have Word though, the free OpenOffice or LibreOffice word processor should do a decent job. It’s PDF generator is good, and its .doc/x converters are some of the best you’ll find outside of Microsoft.

I don’t think save to pdf comes built in with Word? At least, I was fairly sure my Acrobat conversion tab got added after I installed Acrobat Pro… could be wrong, since they were both installed within pretty quick order of getting my laptop.

You can download it. Search for other versions if you don’t use 2007.

microsoft.com/en-us/download … px?id=9943

I use Office 2010, so maybe it came with that? I don’t know, I have Adobe Reader installed, not Acrobat, so I’m not sure where else it could have come from.

Well, unfortunately, Word XP (that’s Word 2002) doesn’t HAVE “save as PDF.”

And I can’t afford new software just yet. Something to do with Hurricane Isaac killing our air conditioner and costing us around $6000… but of course, it wasn’t the power surges from the power company that did it, so insurance doesn’t cover it. (Never mind… if you get the idea I hate insurance companies, you’d be right.)

Definitely try grabbing a copy of OpenOffice then. It’s free, and like I say it has a pretty good PDF generator and DOC reader.

Well, I went in and did something weird… like read the HELP file on my current (very good) PDF printer driver. And figured out how to generate landscape-oriented and both legal (8.5" x 14") ledger sized (17" x 14") PDFs.

The PDFs now look just fine, when viewed in Adobe Acrobat Reader.

But, when imported into Scrivener, they are now chopped off at the right. There is no way to scroll to the right to see the remainder of the file.

Earlier, the PDFs weren’t correct, and that WAS my error. But now the PDFs are correct.

So it does appear that Scrivener won’t import non-letter or non-legal or the closest equivalent to that in A formats. (A4, I believe is slightly narrower and slightly longer than US letter.)

Could you please post the PDF as an attachment? Like I say there is normally no problem viewing PDFs of any size in Scrivener. Try making a PDF with Scrivener and then re-importing it, for instance. So there must still be something odd with the PDF. If you’d rather not post it to a public forum, you can send it to windows.support [size=60]at[/size] literatureandlatte [size=60]dot[/size] com, and past the URL of this thread into your e-mail so the person that gets it knows what it is for.

I have sent the two PDFs in question to windows.support at literatureandlatte dot com (with appropriate substitutions), and with the URL of this thread. Thanks for checking them.

Thanks, how did the experiment go with making an A4 landscape PDF using Scrivener’s compile settings and then re-importing it?

Apologies… how do I do that? I clearly got lost in the discussion of Word and Open Office.

How can I make a PDF from within Scrivener if I can’t get the material into Scrivener in the first place?

(I am somewhat muzzy today. I was up all night with my Sunny Lady Dachs. We lost her around 3:30a US Central Time to throat cancer. She was 14 years, 7 months, and 16 days old.)

It doesn’t need to be anything fancy. Just paste a few thousand words of text into a blank test project (I would recommend using Edit/Paste and Match Style since it sounds like you’ve got some heavy formatting issues) and select File/Compile... choosing PDF as your output format. Then expand the compile dialogue (blue arrow button), click on Page Settings, and make your paper setting adjustments. That will create a PDF on your computer somewhere. Just drag it back into Scrivener and see if it looks good.

Sorry to hear about the loss of your family friend. :frowning:

Actually, I don’t think that would work as a test, because the problem is not formatting of regular text.

The problem is the wrapping around of a genealogical family tree which required landscape printing to get it all on a single sheet of paper.


| |
Justin Fitz
m. Connie
1998
|
|

is the kind of thing, only this has dozens of interrelationships and covers at least six generations.

That’s why I didn’t try to retype the whole blasted thing into Scrivener.

I thought about just copying it from Word, and pasting it into a Scrivener document, but I seem to remember that Word has a gazillion formatting codes that can really screw things up if you do that.

I have two of the three charts now (thank you, Jennifer!) and now know that, as with the export problem I had awhile back, this is a known issue for Scrivener.

It figures. I always find the entertaining bugs in software without meaning to.

I thought the basic problem however is that a wide PDF you created was showing up in Scrivener in such a way that it could not be scrolled. If that is the case, it shouldn’t matter what is in the PDF, just that you have a wide PDF. If you create a PDF from Scrivener (even if it is just blank with nothing in it at all, it really doesn’t matter what is in it) that has the same proportions as the other PDF, and it drags into the Binder and shows up in the editor fit-to-width or scrollable, then we know something is strange with the original PDF, not Scrivener.

The wide PDF could not be scrolled, that is correct.

However, when Scrivener imported it, it also cropped it from landscape to a portrait width by wrapping the lines that didn’t fit.

I don’t know if it will do that in regular wrapped text, as opposed to the genealogical tables.