Papers 3 Citations Not Working After Update?

After the latest Scriveners update, I am no longer able to insert citations using Magic Citations via Papers 3. I can invoke Magic Citations in Scriveners, find and select the references I want to add, but no citation key is inserted into the text. Copy/paste from Papers 3 into Scriveners works but the having Magic Citations was the ideal workflow.

Anyone else with this issue? Any fixes? Thanks in advance for your help!

I recommend getting in touch with the Papers people. Nothing has changed that would affect this in Scrivener, and from your description, it sounds as though the issue lies in Papers sending information to Scrivener. Is Papers 3 even available any longer? It looks as though they only have a web version now and are planning an updated Mac version for December.

Just to clarify, are you saying that Papers need to update itself to be able to send citations to the updated Scriveners app? Their last (and likely final) update was this past June and Magic Citations was working fine with Scriveners up until the most recent Scriveners update in early November. After some exploring, Magic Citations still works in other applications like MS Word.

Papers was sold to ReadCube and they are launching a subscription-based reference manager (still in beta though). I don’t think Papers 3 will be supported going forward but will continue to work.

No, he’s saying that nothing about Scrivener has changed that would break Papers, so you should contact Papers support to see what’s going on.


Where can I even download Papers 3 to test it myself? I can find no download link on the website.

Are you using the Mac App Store version of Scrivener or the one from our site?

Could it be that you also happened to update to a newer version of macOS around the same time you saw this change?

They removed the Papers 3 website and replaced it with the hybrid Papers/ReadCube. The .dmg can be downloaded from CNET here ( … 28287.html) and used with a free trial I believe.

I’m using the Mac App Store version of Scriveners. Yes, I think I updated MacOS and Scriveners around the same time.

Thanks, I’ve downloaded it - how do I test the Magic Citations?

(I had to download the L&L site version of Scrivener 3 as my MAS version crash on opening)

Magic citations (which isn’t very magical) is invoked by rapidly clicking ctrl twice. It opens a small search window with which you can search your own Papers library.’

I run Mojave, I run the latest version of Papers 3, I run the L&L site of Scrivener 3: Magic citations work just like before.

With Scriveners open, double press the Ctrl key to invoke the Magic Citations pop-up. Find the reference you want to insert into the text field. It should be added as a reference key but on my computer it shows up blank.

I haven’t had any crashes using the Mac App Store version, however. I tried downloading the L&L version but it didn’t resolve the issue. I’ve sent Papers an email to see if they have any ideas.

On mine it showed up just as it always has so it’s probably something with your setup. Have you tested to reboot your Mac?

Yes, I tried rebooting but to no avail. Here’s my set up:
MacOS 10.14.1
Papers 3.4.18
Scriveners 3.1 [9841]

Are we using the same versions of each, LUNK? Thanks.

UPDATE: Not sure how it happened, but Papers 3 citations was unchecked under the Privacy settings in MacOS. Having this option checked resolved the issue! Must have reset permissions after the latest MacOS update… Thanks for everyone’s help!

As I wrote above, the latest version of Scrivener from the L&L site, because the App store version vrash on start at the moment, awaiting an update, which is 3.1.1 (9852)

I’m still not clear what should be happening here. I hit Ctrl twice on the keyboard and I get a search window. I search for something and the I have the options to show in Papers, copy to clipboard, search another paper or use Quick Look. I choose “Copy to Clipboard” and paste into Scrivener without any problem, but I’m assuming there should be some option that is more automatic than this?

It works like this:

You press ctrl - ctrl and get the search window:

When you double-click the wanted reference you get a new contextual menu:

And when you double-click on Insert citekey you get the citekey in the text.

When all is done you compile to .docx, open in Word, press ctrl-ctrl and get the option to expand the citekeys and to create a bibliography.

I see no such option - perhaps you had to set Papers up in some way to make this option available? If so, how? Or could it be a limitation of the trial?

You need to have the references in Papers to begin with. From your screendump it looks as if you are somehow searching from within Scrivener?

I’m not sure what you mean. That screenshot is from Papers. I’m just searching for the built-in example references. I get no “Insert Citekey” option.

Ah… you should use the magic citations inside Scrivener. You are doing it in Papers. That’s why you get the wrong menu. Papers can’t insert citations into itself.
You don’t even have to have Papers open. Just press ctrl-ctrl in Scrivener, while editing.

A-ha! Thanks, that did it, d’oh. :slight_smile:

Okay, so when I tried this, I got the same result as writersblock. Mojave told me that Papers wanted to control Scrivener; I clicked “Allow”, but nothing happened - no citation was added, even when I tried again. Here’s how to fix it:

  1. Go to System Preferences > Security & Privacy.

  2. Select the “Privacy” tab.

  3. Select “Accessibility” on the left. You will most likely see that “Citations” is unticked.

  4. Unlock, enter your user password, and tick “Citations”.

Doing that got everything working for me.

This is a problem in Papers, by the way, not in Scrivener. With the added security in 10.14, Apple Events between apps ca be blocked if the app trying to control the other doesn’t meet certain requirements, and that seems to be what is happening here. It may be because the “NSAppleEventsUsageDescription” key is missing from the info.plist file in the app (although I thought that was only a problem for apps built on 10.14 and above, which I doubt Papers is if the last build was from March). You will want to get in touch with Papers and tell them that “Citations” is not getting ticked by default in the System Preferences “Privacy” pane, even though you choose to grant Papers access to control other apps.

All the best,