Para indenting in compile (again)

Scrivener 3. I searched and didn’t come up with an answer. When I compile, I lose my para indents even though in the format option for that style I am specifying do not change. All the other formatting options for that stye are being followed.

I wonder if it’s because the paras aren’t formatted correctly in my source – I just use return and let the editor indent the para. The style is marked as ‘no style’, but I do see the carriage return marks at the end of the previous paragraph.

I must have changed some setting because I swear this was working until recently. Any ideas? Thanks!

I have found the feature that says ‘preserve tbs and indents’ – that seems t fix this, but Id prefer a more reliable method to indent just the paras so I don’t preserve something I’d rather wasn’t preserved!