Paragraph alignments not saved in script settings

Paragraph alignments in the script settings dialogue are not being saved properly.

I think this happens when the user changes a setting, and saves over the original file.

The problem is that the script format .xml file is missing the element:

Center

Hi - just checking that you’ve logged this small irritation for the next release…

It looks like all paragraph alignments in script settings are reset to ‘Left’ when a project is opened.

The best work-round I can find is:

  • save the script format to file from the script settings dialogue
  • locate the script format .xml file (in \AppData\Local\Scrivener\Scrivener\ScriptFormats)
  • manually edit it and add in any missing Center entries - which are the first line in the sections.

Now, whenever you reload your Scrivener project, you must also reload the script settings file in the script settings dialogue. If you make ever save your script settings file, then you’ll need to manually edit in the lines again.

Needless to say, perhaps, this is a real pain.

This has become a major irritation. I have to reset the paragraph settings every time I do a compile. Is there a fix in sight? EDIT - I’m not asking for a date for the next release, but no-one’s confirmed to me that this has been noted as a bug yet.

Argh, I’m so sorry, I filed this as part of a big stack of things and forgot I didn’t also reply to you here. Yes, the bug should be fixed for the next update. Thank you for the report!