paragraph and line spacing problem

Hi,

I have been trying for days, to make my paragraph spacing before to 0pt, after to 12pt and line spacing to 1.5 during the compile.

However when I set paragraph spacing(before=0, after=12pt) and set to single then the program does not save the setting, afterwards when i verify it again the program has changed it to before=12pt and after=12 pt.

Now when I choose multiple, then it allows me set both paragraph and line spacing. Here when I set, paragraph before=0, after=12pt, line spacing=multiple at 1.5 and look afterwards to check whether the setting has been saved, the program does not save with before=12pt(0 was set), after =12pt, line spacing=multiple,1.5

I want to have paragraph setting as- before=0,after=12pt and line spacing as-single and 1.5

How do I do this? will it not work?

btw scrivener is great

Thanks and regards,
Suman

Hi,

Can anybody help me in this?

thanks

This appears to be a bug that has been fixed with the next release, currently in public beta.

I should also note that it looks like you can get around the bug in 1.6.1. The problem only happens when you pull up the settings in the indent and spacing tool, but at no other time (when examine passively with the Format Bar tool, it reads out correctly). In other words I can type in everything correctly, “1.5 0.0/12” or “1.0 0.0/12” and click Okay then compile. The result will be accurate. It’s only when I use the tool to examine a paragraph that it inserts the invalid 12/12 value (but you can just go ahead and zero it back out then and then before clicking Okay). Is this not what you’re seeing as well?

Like I say though, it looks to already be resolved for the future.

Not happening, i tried from format and from tool>option>editor but it does not save the required setting.

Is this a bug? is there any alternative way to solve this? this will take lot of time for my case to edit.

Thanks

Okay, could you provide precise steps—every single button or menu you click on, to describe what you are setting, where you can first detect that the setting is not saved, and what tool you are using (again with each button click enumerated) to verify the settings are lost? I’m a bit confused at this point because originally you mentioned wanting to set this for when you compile, but application defaults, such as the Editor tab in settings, aren’t going to have anything to do with compile settings.

As I say, I cannot see any evidence of formatting being lost. The only bug I see is when I pull up the dialogue box again or use the Format Bar, rather than just looking at the readout. That bug has already been fixed.

In my testing, I was applying these paragraph settings to my Formatting compile option pane and then created an RTF file that I verified in Word (as well as back in Scrivener, by dropping the compiled RTF into the Binder and passively reading the Format Bar settings). I do not see any lost of formatting in that case, so I must not be doing precisely the same thing you are.

Hi,

let me describe my problem

I am using scrivener windows 1.6.1

What I want to do is-
Have paragraph spacing of 12 pts
comment- there are after and before paragraph spacing option and I want after only after
Have a line spacing of 1.5
comment- there are also multiple option for line spacing but I want only single line spacing

What I did:

  1. First
    Go to compile>formatting>select level>modify>line spacing & spacing options as shown below-


    here I tried all possible permutation, for example- first, i set paragraph spacing 0 pt for before and 12 pt for after, and left the line spacing as it is. Then saved it and after that when i recheck the setting it has automatically has put the before as 12 pt(initially set to 0pt) and after also to 12pt(this is ok). This is a simple case.
    When I try to adjust other setting it will similarly not work. for example, if I set line spacing to 1.5 and single, then afterwards it automatically reverts it to multiple with 12 pt each for paragraph spacing.

  2. Second
    Only after seeing your comment here, I used the Format option, and the tool>option>editor option and try to set my desired setting

This is a requirement for my report submission and the document is quite large. Using paragraph spacing with 12 pt after and before makes the space between them too large which I don’t want.

Can you help?

Thanks and Best
Suman

any help for me?

I am not sure what else to add here, as it sounds like you are seeing this bug at a deeper level than I am. As noted, this is a known bug that has already been fixed. If you are need to compile right now, you might consider doing so with the beta, as it should not have this problem. If you can hold off on compiling until later, you could wait until 1.7 is official. I’m not sure what works best for you.

thanks AmberV