Paragraph Formatting not saving [FIXED]

Maybe I’ve done this wrong or missed something. I copied and pasted all my Chapters/scene from Ywriter, saved and closed the program, then re-opened it. All my text was in 8pt size and no indentation for paragraphs.

So I clicked ‘edit’, then ‘options’, and ‘editor’ and noted that the paragraph indent tab was set for half an inch. I left it at that and returned to the main editor - the paragraphs still weren’t indented. I tried selecting what I wanted indented, and then going to the ‘edit’ ‘options’ ‘editor’ etc, saving my preferences. Still didn’t change.

So I selected each scene separately and manually moved the paragraph tab to half an inch. I then saved the project and closed the program. When I reopened Scrivener the project had all the formatting I’d just done removed again.

Maybe I’m just doing something wrong here, so if anyone can confirm whether this is a bug, or let me know the right way to get paragraph formatting to stick, even after saving and closing the program.

Reporting a little more information on “Paragraph Formatting not Saving”

I had a similar problem to the previous report. I was trying to reset the font, font size, and paragraph indent for all the content imported from an RTF file I had already broken into scenes. I had to open each scene separately, select-All text in the scene, select new font, font size, and then move the paragraph indent. This APPEARED to work, but when I came back to the scenes I noticed the following:

  1. MOST of the scenes/files had lost the paragraph indent I had set. I tried resetting the indent on those that had lost the format. This appeared to work, but again when I left the scene, then returned, indent was gone.
  2. A few of the scenes/files had retained the paragraph indent I set
  3. ALL scenes retained the font selection and size that I had set. I would have liked a way to reset these formats universally, but couldn’t find anything that worked.

Nice looking program. I’ll be updating as you release new betas, and continuing to give feedback.

Vanessa

Thanks for these reports. We had some format dropping happening before and I thought most of it was fixed; annoying to see this cropping up again.

As for setting formatting universally: planned feature. It’s simply not implemented yet, but an integral part of how Scrivener works, so yes things feel a bit like there is a missing puzzle piece at the moment. How it will work is your Options:Editor settings can be applied to many documents at once with a menu command.

Thanks for the reply, AmberV. Glad to know the bug report is helpful.

Nice to know that there will be universal formatting. The Windows version is looking very nice in Beta form, and I gather the lags and slowness are issues that will probably be cleared up, so it’s looking great.

It will save me buying a Mac to get Scrivener :slight_smile:
Vanessa

Noted universal font option setting.