Paragraph Indent Not Working

Hi,

I’m not great with Scrivener, as only used it on a few projects so far, and find it somewhat intimidating to be honest.

But as a writing tool, it’s great!

Just updated today (Mac OS) and suddenly paragraph indents are no longer working on new docs.

I’ve been into the editor and everything seems correct, but when I hot return, it goes to a new line without jumping forward.

This happened to anyone else?

Thanks!

I am not sure what went wrong precisely, but it should be pretty simple to get your preferred formatting back the way you want. Find any paragraph in any project that looks right, put your cursor in it, and use the Format ▸ Make Formatting Default menu command. You’ll be asked whether it should be done globally or only to this one project—you probably want the former.

After doing that you’ll need to reset any documents that currently don’t have indents. We have some tips for that in this knowledge base article. If indents still don’t appear, then do check to see if your project has for some reason had its formatting override enabled. You’ll find that in the Project ▸ Project Settings… pane, under the Formatting category.

Thank you for reply. Just tried that. Still not working. See video:

youtube.com/watch?v=6A2vpBE … e=youtu.be

Seems to work perfectly on older projects, but new ones are now doing this since the update.

Thanks for going over the various screens; your settings look good. There are two things of note:

  • It would help to show the ruler in your editor when investigating indent issues (⌘R).
  • None of the sample lines you typed in are long enough to word wrap. First-line indenting will only become apparent once there is more than one line (as opposed to several very short paragraphs).

Ah!!! Thanks so much! None of the lines were long enough! Doh! Feel a bit daft. :unamused:

Issue was me copy-pasting from a Google doc combined with that. I just copy/pasted formatting to those bits I brought in from Google.

Fixed! :smiley:

Yes, that is not an unusual problem! The Edit ▸ Paste and Match Style command can be of use for stuff like that.