Paragraph indent problem, compiling as .mobi (SOLVED)

Hi folks,

I have some body text written into Scriv without indents, and am trying to get the paragraphs to indent in a compile by using compile’s formatting controls (move the stop on the ruler, tick ‘remove first para indent after blank lines’) but when I open the document in an e-reader (in this case, Calibre on the desktop) there are no indents to be seen.

Clearly I’m missing something. Any suggestions?

Cheers

Nathan

Three basic things to check:

  • Is Override text and notes formatting enabled at the top of the Formatting compile option pane?
  • Are all documents in the Contents pane set to compile “As-Is”? If so then they are intentionally ignoring override formatting.
  • In the same panel as where you remove first para indents, make sure Preserve tabs and indents is disabled. That preserves what is in the document, where there are no indents.
  1. Override is ticked.
  2. Documents are not ticked “as is”
  3. in Text Formatting Override Options, “override font only” is the only box ticked

And suddenly I realise perhaps I should untick that…

EDIT: Yup, that worked. Thanks, AmberV!