Paragraph indent when compiling for print in proof mode

I love almost everything about Scrivener, and I’ve used it for nine months now. Just one problem: compiling a proof copy for print drops all my paragraph first-line idents, which makes editing difficult. How do I preserve them? I can’t find a relevant setting.

Thanx in advance!

I’ll take a stab at this, though I may be wrong…

Assuming you have the first-line indent indicator set at some position other than 0 in the ruler and you are seeing first lines of new paragraphs automatically indent in the editor…

In File > Compile > Formatting, uncheck/empty the “Override text and notes formatting” checkbox. Then compile and see if you are getting the desired first-line indenting in the output.

This may introduce other issues or artifacts, which I don’t know enough about to discuss. You might try searching the manual and these forums for “ruler”, “indent”, “override”, etc. to find further discussion of this.

Hope this is of some assistance.

This worked, but it wiped out double spacing, which I will have to figure out as I need that for proofing. h, well.
Thanx!

If you were using override formatting can you not put the paragraph indent into your formatting compile pane settings? There isn’t a specific setting for these types of things, basically the idea is to make the text in the Formatting pane look like what you want the output to be, using the various formatting tools available.

I’ve been brought up with the convention that you either need an indent or a space for a new paragraph. It would be nice if Scrivener’s compilation recognised this automatically. I’ve managed to get it to do this in some instances, by checking the ‘remove first paragraph indents’ box under formatting, but I can’t find a solution to the following problem. I’ve lots of lyrics as exempla, which I’ve put in tables; each line of these has a line to itself. In effect this means each line is a new paragraph - which Scrivener indents (argh). Dragging the indentation back in the formatting box means that no paragraph will be indented…

katiehawks, it sounds like the solution for you is to keep the “Override text and notes formatting” checkbox unchecked (or in whatever way have compile not remove paragraph indents), so compile preserves the /manually implemented/ difference between the two sorts of paragraphs that you are working with. Unless I am missing something, seems to me the fact the you have two distinct ways you want paragraphs to be treated tells us that there is no good way for Scrivener to automate that distinction for you.

I would try playing with the Format/Formatting/Preserve Formatting feature. It is specifically designed for things like this, where localised areas of the content need special formatting. It’s like turning off the format override checkbox, but only for the section marked in blue.

I don’t know, maybe a single-col table is precisely what you need, but that seems like a lot of extra work to me.

Another alternative that might be good for you is to cut the whole song into its own document and set that document to “Compile As-Is” in the Inspector. Now you can do whatever you want in here without the compiler coming in and changing it.

So basically here is what you have:

  • You can add first-line indent to all paragraphs using the Formatting pane in the compiler.
  • In Options… of that same pane, you can choose to remove the first-line indent using some logical conditions (like at the beginning of each new document), all in accordance with modern publishing traditions.
  • For bits of text that specifically must not look like the setup in the first bullet, Preserve Formatting is your primary tool, unless it involves whole sections of text—then “Compile As-Is” may be a better approach.