Paragraph margins when pastting between Scrivener and Word

Are there known page margin and/or tab settings that will let me paste from Scrivener, to Word, and back again, while retaining the same displayed paragraph width? I’m using Word 2007 on Windows 8.1.

This is giving me no end of grief. Trying to describe what happens during the round trip is extremely difficult. But basically, no matter what settings I have in either program, when I paste a paragraph from Scrivener to Word, the margins of that pasted paragraph are wider in Word than in Scrivener. When I paste them back into Scrivener, they have the settings that they picked up in Word.

In Scrivener, my default text area is 6.5".

In Word, I have set up the receiving document to have a 6.5" text area, with 1" margins on both the left and right, with the text starting at 0" position. But pasting from S to W, the text still runs past the right margin.

When I have set a new Word doc with NO left margin at all, a 6.5" text area, and a 2" right margin – when I paste a Scriv paragraph that’s 6.5", the Word margins adjust to a 1.25" left and right margins, a 6.0" text area starting at 0", and the pasted text STILL overlaps the 6.0" right margin by .5" inches… which seems like it would be fine, but when I paste that para back from Word to Scriv, it takes on a 7" width.

It’s as though some kind of offset is being added, or subtracted, or something, in one or another direction, or both, consistently, or maybe intermittently… all I know for sure is that I can’t for the life of me figure it out.

Other formatting pastes perfectly between the two.

Any insight into this will be really appreciated. I don’t even need to understand what’s happening: all I really need are settings, in both S and W, that I can set and forget.

Thank you!

Apologies if you’ve tried all this already!

In Word, have you tried pasting with the different methods available on the Paste button? On the Home tab of the Ribbon, with material copied to the clipboard, click on the arrow underneath Paste at the left end of the Ribbon. Depending on the formatting of what’s on the clipboard, you should get something like 3 small icons with 3 choices: Keep Source Formatting, Merge Formatting, Keep Text Only. Hovering the mouse over a small icon will show what will happen if you select that choice. I’d put my hope in Merge Formatting or Keep Text Only, though the latter will also strip out italics, etc.

In Scrivener, you might try Ctrl+Shift+V to Paste and Match Style. This might paste text from Word into Scrivener’s margin settings. Another option is to paste as usual, then use Document > Convert > Formatting to Default Text Style.

Thanks, David.

Those are good suggestions, but solve the problem at the cost of losing all text (character) formatting, and also footnotes and annotations.

Footnotes and annotations actually carry over very nicely between Scriv and Word, but they can’t survive, in either direction, a “paste special”-like operation.

It’s just the margins that behave what seems unpredictably. I’ will think I’ve found a way of doing it, then next time it fails.

I like using track changes in Word, and so I often just Ctrl-C text from Scriv. I paste, edit, and then copy it back. Nice and simple. I end up with wildly different para formatting. I can then do a Default Text Style in Scriv, but that isn’t always how I want the doc formatted.

I can imagine that compiling and then re-importing might somehow let me circumvent this… but these are just the kind of steps I’m trying to avoid.

So I keep coming back to, there must be some setting in S or W or both that would let these two otherwise very text-compatible programs swap text without something funny going on with the margins.