Paragraph Spacing Mystery?

Hello all.

I was just working on a paper for school earlier this week, and ran into a bit of a problem. In Scrivener, I had each section of the paper – the introduction, the thesis, etcetera – stored in a different Scrivening (i.e., text document) in a single folder in the Binder. What I wanted to do was to be able to write the paper in segments and then let Scrivener glue the whole thing together seamlessly, with no blank lines between the individual Scrivenings. I went to Format > Text > Spacing…, and made sure my paragraph spacing was set at 0.0. In Compile, I had my line-spacing set at 2, and all the separators set to be a “Single Return.” I had also made doubly sure there were no extraneous line-breaks or carriage returns at either the start or end of any of the documents, and my compile settings were set for Print (not going to an external file). However, when I hit Compile, what came out of the printer reflected all my settings except for the fact that between each of the Scrivenings was a mysterious blank line. I was confused; it certainly didn’t display that way in “Scrivenings” mode, so why did it do this? So I went back and double-checked all my settings, but could not find anything wrong; given those settings, I should’ve had seamless document. I turned on invisibles, but saw nothing amiss there, either. Is there some answer to this that I’m just not seeing? Or something that I’m overlooking? Or is it, as I think I read somewhere else on the forum, a bug of some kind?

All the best, mainly just curious

If everything is set to double line spacing, then you would have a single empty line between texts the same as there is a single empty line between each line (this being the nature of double line spacing), so I’m sure that’s not what you mean.

How have you got your “Formatting” pane set up in Compile? Is that set to override the text and notes formatting? If so, what paragraph formatting is set there, have you checked? That might be set to have paragraph spacing before. Also, is the “Formatting” pane set up to insert titles for text documents? If so, check that the title paragraph formatting isn’t set to have extra spacing before each paragraph.

All the best,

Okay, I’ve got it figured out now. I had to click on the Transformations pane and tell it to “convert multiple spaces to single spaces.” For some reason, when I initially saw that option, I thought it meant spaces between words, not lines. But it works now, so yay!

That option does mean spaces between words so should have no effect… Unless you have some extra spaces after those text documents that is causing the extra line, of course.

Huh, that’s extremely weird, then. It must have been something else that I did, then, because I played around with several different options. Oh well, it’s working now, so I suppose that’s what counts.