Parenthesis (Script writing)

In the Script template, writing dialogue, if I start a parenthesis “(” I am presented with the options (PAUSE) and (BEAT). I’d like to add some additional options, such as (LAUGHS), (QUIETLY), etc. These are not stored under Auto-Complete. Can I do this?

Hi,

If you go to Format > Scriptwriting > Script Settings, you will see that these auto-complete words can be found in the “Auto-Compltete” pane for the “Parenthesis” element. You can add others there.

Hope that helps.

All the best,
Keith

Thanks for the Parenthesis hint. I found it.
I have another Scriptwriting auto-complete problem and I can’t work out how it happens. Unexpectedly Scrivener grabs a whole paragraph of dialogue and adds it to the auto-complete list. I suspect this happens when I am editing and/or splitting dialogue between speakers. It’s irritating though it can normally be fixed by removing the line from the Project/auto-complete list. But sometimes the line is “sticky” and persists through several deletions.
Any hints on how to deal with this?
Ian

Hi Ian,

There are two parts to this, and I don’t have a solution for you off the bat but you might be able to help me provide one:

  1. Can you find a particular case where dialogue gets added to the auto-complete list? Only character names and locations should be added to the auto-complete list by default, so this should only happen if you are on a Character or Scene Heading line. If you can try to find steps which will help me reproduce a case where the auto-complete list is being updated with something else, I’ll look into it.

  2. I too have seen the case whereby if you delete something from the auto-complete list, it doesn’t delete and is still there next time. However, I put this down to my imagination at first, because every time I would then go and delete again and it would work fine. But then it happened too many times for it to be my imagination, and so it is on my list of bugs to investigate. However, I’ve been unable to find a case where I can reproduce the problem consistently. If you can find a situation where you can get this to happen every time in a particular sequence - that is, do such-and-such, delete something from the auto-complete list, then open it again and the item will still be there - I’d be very grateful, because I know the bug is there but I haven’t been able to find the trigger as yet.

Thanks and all the best,
Keith

I tried to reproduce it and of course, couldn’t. I’ll go through the motions tomorrow and sort out when it happens.
Cheers,
Ian

Thanks for trying! Let me know if you manage to reproduce either. The auto-complete item deletion is particularly annoying, as it stung me a few times while creating templates but, Uncertainty Principle-like, it refused to play up when I was looking for it.
Thanks again,
Keith

HB asked whether I could reproduce this problem. I began a new Script today and it happened immediately. I’m using the Stage Play (UK) template.
My Script is basically a lecture with interjections from the floor, so I wrote the Lecture first using Character & Dialogue format, ie. a monologue from the LECTURER. I then added the interjections by:
(a) Insert the cursor in the LECTURER’s speech and hit Return twice.
(b) In the space created, add the new character (HECKLER) and his line
© Create a new LECTURER line and backspace the split speech so it forms the next portion of his dialogue.
RESULT: The whole of the remaining speech becomes an Auto-Complete. I guess it thinks I am creating a new character.

If, instead of © I go to the beginning of the line, type LECTURER and TAB, everything following turns into capitals.

There doesn’t seem to be a way to split a speech and insert another character’s line without one of these two problems occurring.

Cheers,

Ian

Hm, in © if you hit tab or enter, it only makes the following dialogue capitals if your tab/enter was on an auto-complete. If you type a new character name that isn’t in your auto-complete list, hitting tab to indent the rest of the line as dialogue does not cause the capitalization.

Additional note, the separated dialogue gets added to the project auto-complete list as soon as you hit the second return in step (a).

You’re right. I seem prone to collecting large numbers of auto-completes which involve me in regularly having to purge the Project/Auto-complete List. The process becomes irritating. My Wish List is for a way of turning off the automatic creation of Auto-Completes in “Character & Dialogue”, so that I’d can just manually add the ones I want to the list. Maybe it’s there somewhere and I haven’t found it.
Cheers,
Ian

Ah, that’s doable, yes. In Format>Scriptwriting>Script Settings… go to the Auto-Complete tab and then go through each of your elements and deselect the checkbox to “Automatically add phrases to project list”.

If you want to fine-tune your control even more you can deselect the box to “include project auto-complete list” and instead enter the items to each element’s auto-complete list there. That prevents you from getting your setting auto-complete words in your character line and so forth. (Of course if you have some names that you use throughout and like the auto-complete for dialogue, etc., you might not want to turn that off for all your elements.)

Just to let you know that these problems - I hope! - should be fixed for the next update, as I spent some time on them last week. There should be a 2.0.5.5 beta available in the beta forum ( https://forum.literatureandlatte.com/t/scrivener-2-x-update-betas-download-here/11262/1 ) with these fixes later in the week or early next, too, so I’d be grateful if you could test it when it becomes available and see if these problems are sorted (the current beta is 2.0.5.5 build 9981, so just look out for a 2.0.5.5 beta with a higher build number at the end of the week or next week).

Thanks for bringing these problems to my attention.

All the best,
Keith