Paste and Match Style not pasting indents

I’m trying to copy and paste the style I’m using in a document (using cmd-ctrl-opt-shift), but while this pastes the font, size, line spacing etc, it isn’t pasting the indents - normally a new paragraph is indented by about four characters’ width. How can I solve this? (Scrivener v3.2.3)

Edit: while I have you there, there used to be a keyboard shortcut, involving F6, I think, for cycling from project to project. I can’t seem to find it now… (D’oh, no, that’s Word; it’s cmd and the key with the tilde on it, beside the left-hand shift key)

If you are actually employing Paste and Match Style, then you are not pasting the font, size, or linespacing info, nor the indent setting. Paste and Match Style just uses the text on the clipboard (plus things like italicization info). The appearance of the result is determined by the appearance settings in force at the insertion point.

Well then I’m not. What I’m using normally pastes the style, not the copy.

To clarify, to bring the formatting of the source document along with the text, use the standard paste. To match the text to the destination document, use Paste and Match Style.

To copy/paste formatting specifically, without the text, use Format → Paragraph → Copy/Paste Paragraph attributes. I would only expect this to work between Scrivener documents.

You can’t paste a style into Scrivener if the source is Word or anything else but Scrivener – formatting yes, but style no – and I can’t figure out what you mean by “the copy”.

1 Like

P&MS ignores italics, bold, etc. in the source. If the cursor is in regular text, it changes the source text to regular. If it’s in italics text, it changes the source text to italics (all of it).

Yes, it’s Scrivener-to-Scrivener. I’ve brought copy in from another project and am trying to match it to the copy in this project.
Ah, Format > Paragraph > Copy Paragraph Attributes and then Format > Paragraph > Paste Paragraph Attributes worked, and there are keyboard shortcuts for both (cmd-ctrl-C and cmd-ctrl-V).

1 Like