Paste links so that they are automatically clickable

Hello everyone

When I paste some links in my editor, sometimes they are automatically recognized and pasted as clickable links, sometimes not.

It seems that Scrivener does not automatically recognize links « https:// »

How can I make sure that every link pasted into Scrivener is recognized as such?

many thanks

Check in Menu: Preferences, Corrections for your setting for “Data-Detection”. For me “Automatically detect web addresses” is checked ‘on’ and it works for me. I guess as long as your web address is recognisable by Scrivener and this option is checked ‘on’ it should work. No?


Thank you for your answer

Automatically detect web addresses" is checked ‘on’ in my own preferences too. But it wors for http link, not for https links… :frowning:

Odd. I tested the URL to this and it works for me.

" (removing the quotes, of course)

Your version up to date?

Your link works.
Not this one.

What about you?

PS: version 3.2.2

That works fine for me, on macOS 10.14. I’d run your test over in TextEdit as well, with its Edit ▸ Substitutions ▸ Smart Links enabled in the document, as Scrivener isn’t doing anything here but having the system itself look for URLs.

Hi Amber!

Oh, TextEdit at home was
Edit ▸ Substitutions ▸ Smart Links disabled

I turn into

TextEdit / Edit ▸ Substitutions ▸ Smart Links enabled

And nows links seems to work with Scrivener :slight_smile:

Is it the trick ?

All my best,

TextEdit’s settings should have no cross-feed with whether or not Scrivener does anything with links, nevertheless which links would work—but I suppose in an esoteric, logjam deep within the clockwork of the operating system way, perhaps toggling it on and off in TextEdit caused the subsystem to start working again beneath Scrivener. :laughing: Your guess is as good as mine on that one.