pdf and image problem

Hi all, I’m searching a turn around for a problem with pdf compiling.
PIctures are cropped on the right. I though it was a centering or an image size problem, but I can’t get it right.
When generating ePub everything is correct, on pdf it seems to be a very strange behavior. Get the picture really small make it fit to the page but it’s like there is a limit size, under 400px width it’s ok for centering or fit to page, more is giving the same rendering problem, block to the right and cropped.
anyone any ideas :question:
thanks a lot for helping

Hi

That is very strange. Which version of macOS are you on? Could you possibly attach the image causing the problem (or email it to us for my attention) and also let me know what page size you are using, so that I can try to reproduce the issue?

Thanks and all the best,
Keith

Could it be be the paper size (found in page attribute) ? It’s sized to fit exactly the print necessity on amazon (see screenshot) But anyway there should be no problem, text under images is correctly wrap.

You’ll find one png attached for try. In the page, it’s inserted and resize to 550px. As I said, I tryed 600 700 or 400 and the render is allways the same.

thanks a lot for your help

Thanks for that. I think I’ve found what is going on - the image is indented, which is pushing it off the edge of the page by the size of the indent.

Try this:

  1. Select the image.

  2. Show the ruler (Cmd-R).

  3. Look at the first line indent. This is what you get if you just imported the image without changing any formatting:

[attachment=0]Screenshot 2020-09-22 at 14.03.34.png[/attachment]

  1. Note how the first line indent is in from the edge of the page. Drag that all the way to the left:

[attachment=1]Screenshot 2020-09-22 at 14.04.17.png[/attachment]

That fixes the issue for me. That said, if your Compile setting overrides formatting, that might add an indent again. In that case:

  1. You could centre the image using the text alignment controls. Indents don’t get added to centred text (depending on your settings).

  2. Or, after removing the indent from the image in the text, you could select the image and apply “Preserve Formatting” (via the Format menu), which would ensure that Compile did not add any extra indents to the image.

Hopefully that will resolve the issue for you. To me, this looks like a minor bug with Apple’s “fit to page” code which I use for images in page view. I’ll have to see if there is a workaround, although you wouldn’t want the image indented anyway so you would need to ensure there was no indent on the image even if this issue didn’t exist.

All the best,
Keith

Oooooh, so great ! thanks a lot, that works with moving the indent and force keeping format. That made the thing simple… you are the one ! :mrgreen:
May I ask “why” those indents are automatically created when creating new text ?

thanks a lot for your time .
.F

ps : Btw, I noticed 2 little bugs as I practiced images a lot last day… :smiley:
Sometimes when double clicking a picture to get the resize box, the image is compress to 30px width ! You have to cancel and the second time double clicking, the size is kept.
When changing the width and moving to the height with tab or click, make it adapted ( if the checkbox keeping ratio is ticked.) Doing it the other way is not working, you can’t change the height and have the width recalculate.

Glad that helped.

That’s just the default paragraph formatting. You can change the defaults via the Preferences.

I saw something like this happen earlier bizarrely, but I haven’t managed to make it happen since. Have you got any steps or images that make this happen consistently?

I’m not quite sure what you mean here - you can move either slider to resize the image.

All the best,
Keith

not really, but you can take the image I uploaded previously.

What I tryed to “badly”(sorry) explain is :
Let say you have a 200w x 100h
by default when coming on the popup, you come on the width edit box. Change it to 100 and then select the height edit box. This one will be reevaluate and is now 50. You can play with slider and you’ll see values changing.
cancel and close the box and come back to it.
Go directly to the height box (actually 100) Try to change the value to 50, and select the first edit box … the width will not be recalculate and you ear an alert sound.
Try the to use the slider and the value you entered will not show any change, it’s not the same behavior as the first try.