PDF image bounds

Scrivener 2.0.5 (9496)

I’m evaluating the product at the moment and it looks like it’s going to be a great tool for me in creation of largish technical documents.

Alongside what it does with text, which is what I’m mainly interested in, I work with lots of vector format diagrams which Scrivener seems to handle fairly well but only up to a point.

One package that I use a lot is EasyDraw.

I can place EasyDraw drawings into the collection so that I can work with them by clicking them and having Scrivener activate EasyDraw - That bit works fine.

I can then paste the vector graphics from EasyDraw into my draft and distill it to RTFD for layout in Pages which also seems fine, however, the graphic in pages seems to have the full page boundary of the document and not just the bounds of the graphic i.e. I have a drawing on an A4 page taking up a small part - when I look in Pages I have a bunch of whitespace around that drawing.

Things I can confirm…

  1. The bounding of the pasted image within my draft in Easydraw is cropped nice and close to the image, no superfluous whitespace… certainly not the whole A4 page area.

  2. The object type in Pages is a pasted PDF.

  3. Pasting directly from EasyDraw to Pages produces a correctly cropped PDF image around that area.

The reason this is important to me is that I will have a huge collection of images and vector drawings in some of my projects and want to deliver my final Artwork through the distil process into RTFD so I can work on page layout in Pages. I’m not working as a team with a graphical designer, these are simply documents that I produce on my consultancy exercises and as such I’m really looking for a tool that can keep everything together for final output but give me better features for gathering my notes and ideas and cross referencing etc.

So, any thoughts on the PDF bounds?

Cheers,

Andy

Hi Andy,

Thanks for trying out Scrivener. Could you please try out the following test, which will determine whether this is a limitation of the way RTFD handles such vector graphics?

  1. In Pages, paste in an image so that it looks as you want it.

  2. In Pages, go to Share > Export… and export to the RTFD format.

  3. Close the document.

  4. Now open the RTFD document you exported in step (2) in Pages.

Does it still look fine?

Unfortunately there are some limitations with working with Pages (in part because Apple don’t make it possible for third-party developers to support the .pages format directly).

Thanks and all the best,
Keith

Keith,

Yes, thanks I should have tried that first and yes, it does keep it’s image bounding when it’s exported from Pages (RTF is the only option but it comes out as RTFD when doing this) and reloaded into Pages.

And the format of the object is still PDF.

I have attached a sample RTFD document with a non business graphic that I made.

Now, the really spooky thing is, I can’t for the life of me get Scrivener to produce a distilled version with anything but a TIFF in it to send you a version to compare against. It may be I’m getting tired, I’m working on an assignment in Dubai at the moment and have been on the case for 12 hours straight :stuck_out_tongue:

Anyway, the attached file might give you some clues.

Cheers,

Andy
dogrosetest1.rtfd.zip (8.3 KB)

Hi Andy,

I copied the document you send me into Scrivener and exported to RTFD, and the images were fine - they appeared in the RTFD file as .pdf files and looked fine in Pages. Here it (with some other placeholder text) in an RTFD file exported from Scrivener and opened in Pages:

So I’m a bit confused, sorry! Sorry to ask the obvious, but did you definitely export to RTFD and not to RTF?

Thanks and all the best,
Keith

Hmm, I can’t get it to compile at all now and produce a PDF file embedded in the RTFD file. And yes I’m using RTFD, when I distill. I tried RTF to see if that’s any different and that comes out without any graphic at all.

I seem to get alternating behaviour now with the distilled document either carrying a ‘Pasted Graphic 1.tiff’ or a ‘Pasted Graphic 1.png’ if I look at the Metric inspector from the image within Pages… of course it looks exactly like your screenshot but it’s raster and not a PDF vector file.

This is starting to get confusing because I don’t seem to be doing anything different when I paste the graphic and distill it but it seems to be random if I get png or tiff at the moment and I’m never getting pdf any more. Very strange indeed.

Andy

Hmm. This sounds to me like someone needs to go to bed (and unplug the computah).
:smiley:

Dave

Slept already, back on the job again and refreshed :mrgreen:

Problem solved, many thanks for your patience with a tired old consultant.

Here goes…

  1. I tested again, this time not pasting from EasyDraw but using Preview to clip an area of PDF. Dropped that into the test doc, saved and distilled… result PDF :slight_smile:

  2. I was now wondering about the clipping format on EasyDraw and after a little digging I found that the copy and paste order had TIFF listed first. After changing it to this…

…the problem of course went away :slight_smile:

Interestingly if you paste from EasyDraw to Pages etc. you get PDF anyway so there’s something going on with preferred formats related to clipping services but this seems to be a good fix.

I’m assuming that I must have got confused and pasted a PDF output in rather than a clipping before which accounts for the image bounds issue (I was very, very tired - sorry!) but this makes EasyDraw work nicely producing nice vector drawings distilled into the RTFD.

Again, many thanks for the help and I’ll put it through some more serious testing now :smiley:

It might be worth summarising this, retitling and stickying it for EasyDraw users.

I’m assuming that Scrivener just picks the first enumerated Pasteboard format on a paste operation rather than looking for preferred formats in a specific order?

Glad you got it sorted! (By the way, RTF does embed images, although as PNG or JPG format, it’s just that Pages’ RTF importer is rather poor and doesn’t support images so strips them.)

As for pasteboard formats, no, all programs pick preferred formats first, and then move on to the second preference and so on. Scrivener uses the standard OS X text system, though, and doesn’t change anything about the preferred formats in the standard text system - so I guess it prefers TIF format over PDF. Apple built an entirely different text system for Pages, and from what you say, it seems that they have prioritised PDF there, in contrast to the text system they provide for developers to use.

But wait… I just this minute downloaded EasyDraw, created some shapes, and copied and pasted into Scrivener - and ended up with PDF data in there without changing any settings in EasyDraw. So the text system in this case chose PDF over TIF (both were available on the pasteboard, I checked). Strange!

All the best,
Keith

There are some differences between the AppStore version of EasyDraw (which I’m using) and the one he sells from the main site around supported file formats. Maybe other stuff too of course.

Aside from that I can only assume it may either be OS version, component version etc. (I’m using 10.6.7 with all updates) or some other app changes some Text system property that alters the preferred formats order.

I only tested the version on their site, but the preferences are the same as the screenshot you showed, and I’m on 10.6.7 too - odd! At least you’ve got it working, though.
All the best,
Keith