PDF to Scrivener not working

I’ve got Scrivener 2.0.5 (upgraded from 1.x) and cannot get the PDF to Scrivener feature to work. I checked the documentation and it says, “Note that if this fails, you may have accidentally attempted to import the PDF file into your draft folder. Make sure another folder is selected before attempting to use this.” I made sure I selected the Research folder (Why isn’t this done automatically?) and it still didn’t work.

I saw literatureandlatte.com/wiki/ … pp_store&s[]=pdf&s[]=scrivener and tried creating a link in the ~/Library/PDF Services directory:
ln -s /Applications/Scrivener.app/Contents/MacOS/Scrivener .
That created another entry on the PDF menu, but Scrivener complained about the format when I ran it (and it opened a second copy of Scrivener).

In the ~/Library/PDF Services directory, I saw a zero byte file named Save PDF to Scrivener . Finding https://forum.literatureandlatte.com/t/whats-the-problem-with-print-pdf-to-scrivener/10914/2 I closed Scrivener and deleted it. Sure enough, Scrivener created a new zero-byte file which still doesn’t work.

How can I fix this?

  • George

Mainly because that isn’t predictable. You picked Research, another person might want a folder named “Read Later”. I suppose a fall-back to the root level wouldn’t be a bad assumption.

This file, it is an alias, rather than a symlink. Try clicking on the alias in Finder and pressing Cmd-I, and make sure the “Original” line specifies the full path to where you have Scrivener installed. In most cases this will be “/Applications/Scrivener.app” and from your linking example that’s what it should be. If Scrivener is installed elsewhere, you’ll want to click the provided button to select a new original.

Failing all of that what’s your OS version, and do you get any error data dumped to ~/Library/Application Support/Scrivener/Logs when you try to print PDFs to it?

Or just allow it for Drafts. I don’t know why that has to be special.

OK, did that. Looking via Finder, both have “/Applications/Scrivener.app” for “Original” and are in ~/Library/PDF\ Services. Finder show different sizes for them (193KB for original and 385KB for the new one). Still does nothing that I can see. Shouldn’t I see a new document in the selected folder?

I get a zero-byte file named Console.log My OS is 10.6.7

It’s special because it’s pretty much the whole point of the program. :slight_smile: The “Draft” folder is where you build up your long text document, in chunks, and is used by File > Compile to compile those chunks into a single document for export or print. This is the main reason Scrivener exists. I definitely recommend going through the tutorial project (Help > Interactive Tutorial) to get a grasp of Scrivener’s core concepts if you haven’t already.

All the best,

Keith, does that tutorial say how to solve the PDF to Scrivener bug?

No, because there is no such bug. :slight_smile: Perhaps you could explain, step-by-step, exactly what you are doing? Which application’s print panel are you calling “PDF to Scrivener” from? Is Scrivener open etc.

These problems notwithstanding, as I say, we really recommend that you go through the tutorial in order to get an understanding of the special status of the Draft folder and suchlike.

It happened to be calling print from Firefox, but since it’s a system dialog, it shouldn’t matter, should it? As described previously, Scrivener was open and the Research folder was selected.

I understand the special status of the Draft folder. I also understand that’s a design decision, not a law of the universe. And I understand that the UI displays the Draft folder the same as others, giving the impression that it should work the same as others. And I understand that this is not related to my question, and I wonder why you’re going on about the tutorial when that has no bearing on the problem at hand.

Is this the wrong forum for seeking technical support? I came here with a question about something that’s not working the way the documentation suggests it should. If the only help I’ll get is to be told RTFM, then perhaps Scrivener is not the tool for me.

Well, sorry for trying to help. I told you to refer to the tutorial because you asked why the Draft folder couldn’t hold non-text files, and this is explained thoroughly in both the tutorial and documentation. To say, “It’s not a law of the universe, but a design decision” is like saying that not allowing you to edit Excel files in Photoshop is a design decision of Photoshop - true enough, but meaningless. It is a design decision, yes; and one that has a very good reason behind it, one that should be clear if you have gone through the tutorial and understood the whole purpose of the Draft folder, which is why I pointed you in that direction. I wasn’t telling you to RTFM, but rather pointing you to materials that would answer your question more thoroughly.

Yes, this is the technical support forum, and people are trying to give you technical support - both Ioa and I have tried to help you. But it’s difficult (and not entirely fun) to give someone help when they come back with spiky, overly-critical answers rather than describe what is happening in detail. What is happening (or not) might seem simple enough to you, but as many details as you can provide are always helpful in zeroing in on the problem.

All that aside, if something in the Draft folder is selected, a PDF added to the project via Save PDF to Scrivener should get added to the Research folder regardless - it shouldn’t fail.

I said this isn’t a bug because I’m confident it’s not a bug - I’m confident about this because of how the PDF services work (if I’m wrong I’ll eat my hat and give you a refund). There may be an issue with it right now on your particular system owing to the way PDF services use aliases and are prone to flakiness, but I’m 99.999% sure it’s not a Scrivener bug; thus we need to find out what is causing the problem on your system. Hence the questions…

I asked which application you were trying this from because although it is indeed a system dialogue and shouldn’t matter, it would help me try the same thing from the same program. I just tested it out with Firefox and it worked fine, though. To be clear of my steps, I went to File > Print… in Filefox, selected “PDF” in the bottom-left of the print panel, and chose “Save PDF to Scrivener”. There’s no other way I know of doing this, so I assume this is exactly what you are trying.

The “Save PDF to Scrivener” feature is a system-defined thing, too. An alias in the PDF Services directory sends the PDF file to Scrivener, so it seems as though it is failing to send the PDF for some reason.

If you haven’t already, try double-checking that you don’t have Scrivener 1.x still installed anywhere. Although the path is pointing towards Scrivener in the Applications folder, it’s not impossible that it’s getting re-routed to a copy of Scrivener somewhere else.

Also try moving the “Save PDF to Scrivener” alias from the PDF Services folder to the Trash and emptying the Trash, then relaunch Scrivener. This will cause Scrivener to recreate it.

A PDF file in the Draft wouldn’t make a whole lot of sense except in extremely narrow cases where the PDF file just so happens to be preformatted precisely in the same manner as the settings in the compiler. Page numbers in the same spot, margins the same, font and text characteristics identical—otherwise you’ll get a sudden and strange transition from one layout to another, then back again when the PDF ends. Better to just strip the text content out of the PDF and use it in the Draft so that it can fit in with everything else.

If you really need a PDF image in the Draft (and I recommend only using this for images, and then only if you have no other way of handling the graphic with a raster format), you can drag and drop a PDF into any text file in the Draft—where it will sit roughly like a graphic does. I’d tentatively say that’s only good for proofing though. Since PDF is not a supported embeddable format for the RTF specification, it must be rasterised during compile and this can reduce the quality of the graphic. Far better to do this rasterisation in Photoshop or similar, get the image pressed to size, and use that in the Draft.

Back to the issue: PDFs brought into Scrivener this way sometimes come in as ‘untitled’ (depends on the sending program). Try searching for that in Project Search and see if they pop up somewhere unexpected. I just fired of several tests, from TextMate, Opera, and FireFox 4, and all worked fine on my system. This is 10.6.7 as well; tested in both 2.0.5 and post-beta builds.

So yeah, clearly we are missing some piece of the puzzle. If my system were exhibiting this behaviour, I would try the following (after Keith’s suggestions):

  1. Test printing PDFs from FF to another program that works this way.
  2. Test saving as PDF to the disk; then dragging the PDF into Scrivener
  3. Test using another program (TextEdit is good) to generate the PDF send
  4. Restart FF in safe mode with all extensions turned off and see if that helps

You may want to try logging out of your user account and then logging back in, or restarting your computer, if you haven’t already. Sometimes the services are a little whacky and don’t take properly until you’ve logged out and back in, and it could be that it’s still pointing to a non-existent 1.x file. This happens sometimes when trying to assign shortcuts via System Prefs, so it’s possible that’s throwing this off as well.

I had the same problem: save pdf to scrivener didn’t do anything (Mac OS X 10.6), and it turned out that the alias was pointing to an old version of Scrivener that I had on my system. Once I changed the location in pdf services, it worked.

Perhaps not in the long run, but to me it makes more sense than silently failing the action. But that was just an aside, not the point of my posting.

Other than looking for remnants of Scrivener 1, the previous conversation showed I’d already covered his points. And I have no idea where or how to look for remnants of Scrivener 1 left behind by a default upgrade to Scrivener 2. Does the Scrivener 2 upgrade sometimes leave behind bits that later confuse it?

Yes, that’s always worked. It’s just very inconvenient and makes Scrivener less than desirable for accumulating notes for later.

OK, that worked.

Hmmmm… Now, without restarting FireFox, it works also.

That’s rather bizarre, and it’s unsettling that it’s so indeterminate with no indication of what’s going on. I’ll take it, though.

Thanks for your help, Ioa.

  • George

P.S. Keith, I don’t know why you think it’s “overly critical” to comment on a design decision. It seems to me that you’re not ready to handle support if your immediate reaction is that something is not a bug. Perhaps you should take a wider view of the situation. From a user’s point of view, something that doesn’t do what is expected is a bug even if it’s not a programming error. Your defensive and reactive attitude has certainly weakened my goodwill toward this program, and I’ll give a less enthusiastic recommendation to others.

George - good will works both ways, I’m afraid. My first post in this thread was (at least in intention - I’m not sure how it offended you) a friendly explanation as to why the Draft folder was special, with a pointer towards more info on that subject. True, I didn’t jump in to cover the PDF problem at that point because Ioa was handling it, but from there on in, you have been nothing but rude in your replies, which is against our one forum rule of being polite (perhaps that wasn’t your intention, but that is how your replies read to me I am afraid). To say that I am not ready to handle support is both offensive and patently untrue; if you browse the forums, you will find an excellent level of support and will find that I strive to fix all genuine bugs as fast as I can; you will also see just how much user feedback has gone into refining Scrivener. I already explained how I know that the PDF Service is not a bug in Scrivener. But ho-hum, I shall pass on your complaints about my support efforts to our line manager, and shall then give myself a good dressing down. :slight_smile:

I’m closing this thread now. Please start a new thread if you have further problems.