Peculiar Problem: Spellchecking German only on a UK English System

I use Scrivener 3.x on Windows 10 set to UK English with a US international keyboard. I live in Luebeck, Germany so I switched the date and number formatting to German to avoid confusion with official documents.

Every Application on my Windows System gets spellchecking correct. Scrivener displays the correct user interface, but insists to spellcheck German exclusively.

I know how to use my Windows. I triple checked the usual suspects in Settings. I deinstalled the alternate German keyboard layout and subsequently all support for the German language in Windows. Scrivener somehow still manages to screw this up.

Heading for a nervous breakdown. And please if you have to insist giving me Windows advice, make sure it’s at least genius level.

Thanks a lot.

The setting for spell check language is coming from a setting in Scrivener, not Windows. Open options, and in the Corrections: Spelling tab, set the Dictionary to en_GB. If you don’t see it in the list, you may have to download it.

1 Like