Plaintext compile with paragraph indents (v1.9)

An agent’s submission form wants the first 50 pages submitted in plain text. I can compile it in plain text, but when I do so, there’s no paragraph indents, no lines between paragraphs, no nothing. Just a wall of text. I can’t use that to paste in the box. It’s too hard to read. I don’t want to go through 50 pages manually entering leading spaces for paragraphs or separating them with a line.

Any hints/clues?

Hi chartscharts,

As an experiment, I took a short story I’d compiled to .rtf, opened it in Word and tried ‘Save As’ to .txt.

Enabling option ‘Insert Line Breaks’ during the save process truncates the plain text lines as they are in the Word doc, so the result has paragraph indents and is very readable in Notepad.

That said, there’s no extra space between lines.

But before diving too deep into Scriv compile, you might want to give this a try, to see if it will work for you.

Best,
Jim

I don’t have Word. I’ve got LibreOffice Writer and it has similar options. But I couldn’t seem to get it to work. :frowning:

image
Have you tried these two settings in Compile > Section Layouts > Transformation for the .TXT File Type?

1 Like

Well advised – that works, and a good thing to learn.

You probably also want to check “Convert smart punctuation”, so that curly quotes and apostrophes come out in pure text form – you’ll know it if you miss this.

Particularly impressive is that Scrivener apparently tries to match your look as far as how many lines to put between paragraphs. A 10 pt line spacing gets you one line of txt file spacing, just what you’d want.

The same sort of thing occurs to give spaces to replace the indents you have set. Wonderful.

One thing to be aware of – Antoni, you may have had this set up, but with the standard Plain Text Manuscript format selected in the left column, you won’t find the box listing modifications where you are using that Transformations item.

The trick of it is to select Text Manuscript, and the click the plus(+) key below, and select Duplicate and Edit Format.

There in Edit, you can click the selections, and also (re- name your Format to make it easy to find. You can use the gear-Edit next to the + if you need to modify anything later.

I am particularly impressed to find this, as Pandoc or many other systems can’t apparently do this (not sure Pandoc actually can’t, but people say…). I did think up another way to do it, by using Replace to create double return/paragraph marks from singles in a Copy of your document, then exporting that to text.

This worked, but no indents, etc., and the Scrivener way is much nicer. Once you have it set up as a Compile Format, you can always just use it.

1 Like

Thank you! But I can’t find those options anywhere. Here’s what it looks like for me.

Darn it, I’d love to post what I’m seeing, but apparently, I’m not allowed to put pictures in my posts or put links into my posts. ADMIN CAN YOU FIX, PLEASE?

So I don’t know what to do. That’s not what my “Transformations” window looks like in Compile after I select plaintext.

Good luck, chartscharts!

What version Scrivener do u have? Help > About

Thanks for your patience in trying to help me!

Version: 1.9.16.0 - 14 Nov 2019

Sorry, I was assuming 3.0.1.0. I don’t have the old version running any more, so can’t help you.

I couldn’t find anything equivalent to v3’s plain text handling in v1.9–the older version doesn’t seem to offer those features, although it’s possible I might have missed them.

One option you have is to download & install Windows Scrivener v3.0 on your PC and run it in trial mode. You’ll have 30 days of use to get it to work. :nerd_face:

There are a few things though to be aware of with this approach:

  1. v3 compile has changed significantly from v1.9. There’s a big learning curve. You’ll get new features, but your old way of compiling will no longer work. You’ll have to learn the v3 way of doing things.
  2. When you install v3 on your PC, it will become the Windows default program for .scrivx files. Any project that you want to work on in v1.9 must be opened from within v1.9, using File > Open or File > Recent Projects.
  3. I would strongly recommend making a copy of the v1.9 project you are trying to print to plain text. Let’s say the original project is called My Project.scriv. You’d use Windows Explorer to make a copy of the entire project folder and call it My Project COPY FOR PRINTING.scriv. Leave your original version of the project alone and play with this COPY in v3.
  4. The first time you open My Project COPY FOR PRINTING.scriv in Scrivener v3, you’ll get a message from v3 saying the project’s in an old format and will be converted to the new format. V3 will make a make a copy of the project and call it My Project COPY FOR PRINTING BACKUP.scriv. Just letting you know so this additional project version doesn’t confuse you.

I know that going through 50 pages manually will be a lot of work, but so will trying to learn v3 compile. But I thought I’d make you aware of this option.

Another thing you could try is find a LibreOffice Writer user forum and see if anyone has tips for getting your desired plain text formatting out of LibreOffice.

Just some thoughts. Hope it helped.

Best,
Jim

1 Like
  1. V3 makes a copy when you convert the v1 project.
  2. v1 made a backup every time it closed (by default).
  3. You don’t need more copies; just don’t delete the backups you already have.
  4. A plain text copy is not a project backup. That approach loses metadata, Binder structure, Research, and almost everything else of value in Scrivener. (All but the words.)
  5. V1 is available for v1 projects, no matter what happens using v3.
  6. v3 Compile is not all that difficult or new. See the video.

v1 (or v2) conversion to v3

Thanks! I’ve been wondering when it’ll be time for me to upgrade, and maybe that time has come! Appreciate the confirmation and the hints for the upgrade! Thank you!

I purchased the upgrade, and now see the settings you’re referring to. And with some texts it works perfect! Just what I want. With other blocks, it freezes/crashes (program not responding) Scrivener and I have to Ctl-Alt-Del it to end the program. :confused:

Can’t figure out why it works for some but not others.

By trial and error, I got it to spit out the pages I needed in the end. I ended up having to create “New Text” and then cut/paste from the original into the new one. Why that worked and compiled when the original didn’t is beyond me.

I appreciate the help! I think I’ve got it good enough to submit!

1 Like

I may have an answer for you on this, if not just why.

Yesterday I fought with getting settings to match between Scriv Win3 and Scriv iOS.

It appears there are things that can be written to a docucment or its configuration files which can’t be modified later, or more probably, are superceded by other config you don’t readily see, with the same effect, very possibly by use of Set Format Defaults on either end of the two apps.

The only way I could get out of this was:

  • create a new empty page
  • copy paste the content into the new page
  • delete the old and use its title and position in the binder for the new page
  • set what’s wanted in base format (font base, mainly) by Select All, set the format (not style) on the new page.
  • in all cases, do not use Styles or Set Format to Default on the new page

Should be a clue to somoene, but there are more problems to find., especially for fonts which may not follow fully a conventional naming, so that Bold is in file Fontname Bold, for example, as it is in Aestetico.

1 Like