Playing Linked Audio Files

I like to use audio notes when I’m working on a document or project.

I’ve created a folder under “Research” called “Audio Notes” where I keep copies of my mp3 notes files. I also link to the original external mp3 file in the Inspector->Document References panel.

  1. I can play the external mp3 file that’s linked to in the Document References panel by choosing “Open in Default Editor”.

  2. I can play the mp3 file that’s stored in Research->Audio Notes by right clicking the file and choosing “Open in Other Editor” – in which case the audio player control bar opens beneath the main window and I can play the mp3 from inside Scrivener.

Great, so both of those work.

However, if I create an “Internal Link” in Document References to the Audio Notes mp3 file and try to play it in Scrivener by choosing “Other Editor” (same process as in playing it in #2 above except that I’m choosing “other editor” by right clicking on the internal link in the Document References window), the audio player control bar doesn’t open, and all I get is a blank “other editor” space.

I realize that the mp3 in Audio Notes is an actual object while the internal link in Document References is just a link to that object, but you’d think there would be a way to play it: when I make an internal link to a graphic and choose to open it in “other editor”, the graphic opens. So you’d think that there would be a way to open an audio file as well, unless it’s a matter of graphic and audio files behaving differently.

I believe the ‘other editor’ is a text editor only.

When I right click on an audio file in the Research->Audio files folder and choose “other editor”, it plays the mp3 inside Scrivener (i.e. not using an external program), but rather it opens in the same space as the additional text editor normally opens, below the main text window.

Using “Open in Other Editor” on an internal link from the references should work for audio files. I’m wondering if perhaps the footer isn’t visible in the second editor split? After you load the audio in the split and aren’t seeing the controls, click in that editor to focus it (the header should turn blue) and then check if you can select View > Layout > Show Footer View. Since the header and footer can be toggled on or off for each split individually, it could be that it just got turned off in one.

That was it! The footer was turned off on the ‘other editor’ window. Turning it on brought up the audio controls. But what I don’t understand is why the audio controls would appear at the top of the other editor window when I played an audio file from the research folder, even with the header and footer turned off.