Please HELP! Contents of my project DISAPPEARED

Hi there,

HELP! I am truly desperate! I am writing a paper for a conference that it is coming in a few days. When I woke up today to keep working, I got a strange message saying something like “Warning: The project you are trying to open is from an older version of Scrivener” or something like that, which it cannot be, as I have only used this version, and I have only had two projects going on in the program since I bought it. I pressed “cancel”, as opposed to “Update file to the newer version,” just in case, and closed the program, thinking that was a strange notice. I reopened the program, but surprise, the last project I was working on did not open automatically, as it always does. Worse yet, when I looked under “Recent Projects” and tried to open it, CONTENTS HAD DISAPPEARED. THE ENTIRE BINDER, with all of my notes (3 weeks of notes) had disappeared. Only the TRASH folder is present --not Binder, not folders, not draft folder, not even the “research” folder. Please I need your urgent attention. I am devastated. The consequences of not attending this conference… I cannot start telling you the damage this is causing me. Thank you for your prompt attention.
P.S. I did a search with Spotlight. But the file names ARE there --it takes me to the only two projects I mention. One is fine, the one I was last working on has deleted all of my folders, as explained above.

Okay…

Firstly, do a Spotlight search for Scrivener, to ensure you only have one version of Scrivener on your computer.

Secondly, are you saving projects to the local hard drive? I hope you are not saving them to a network drive or external drive, as this can cause problems in general.

Thirdly, ctrl-click on the .scriv project in the Finder and select “Show Package Contents”. What do you see? Are all the files there?

Fourthly, have you been careful about using the Backup To feature to ensure that you regularly backup important work?

Finally, you could zip up the file and send it to me at support AT literatureandlatte DOT com. I’ll take a look.

Best,
Keith

About your questions:

  1. I only have ONE copy of Scrivener. Spotlight confirmed that.
  2. I only work with the internal hard drive of my computer --not external drives.
  3. I am not sure I understand what to do, even though you explain it well. You say: ctrl-click on the .scriv project in the Finder and select “Show Package Contents”. What do you see? Are all the files there? The PROBLEM is that I don’t see it. I only had two projects in Scrivener: one saved in a “Working Drafts” Folder on the Desktop, the other one just retrieved from the Scrivener program (which I opened every day, without a single problem). The file name is STILL in the Scrivener Menu --I go to File, and there it is, but there is nothing other than the Trash folder when I open it. That’s the mystery to me.
  4. I have not used the Backup feature you mention. I only now realize there is one!
  5. I would love to “zip up” the file, but it is just not there. It is like a phantom “name” on the “Recent Projects” of Scrivener’s File Menu, but there is nothing. I do not understand. Is there any way to retrieve it from some internal folder whatsoever? Where did the contents go? I have a picture of all I had in one screen shot that I took with my “Capture” to show the delights of Scrivener to a friend. I will send it to you so you can see all I had in the binder, which I find hard to believe it just disappeared! Could you help me understand what it might have happened so it does not happen to me again? *Besides learning that there is the Backup feature I should use, of course!

Thank you for your help and prompt reply!
Gratefully,
-luc

Do a Spotlight search for your project and select “Show All” in Spotlight. When you select the project in the Spotlight window, it will show you at the bottom of the window where the project is located. The project must be on your hard drive, or Scrivener wouldn’t be able to open it (even though it currently only opens it as a blank project - if it wasn’t there, it wouldn’t be appearing in the Recent Projects menu). Alternatively, when you open it, ctrl-click on the icon in the title bar of the project - that will give you the path to the project too. Once you have located it in the Finder, you should be able to follow the other instructions.
Best,
Keith

I did the Spotlight search, while also connecting my external hard drive to locate previous versions of the missing file (and see whether I could rescue something). Spotlight ONLY shows me the file (same name) in the backup external drive --the old one, my very first notes, a couple of hours of work. Once I opened that file with Scrivener, now all it appears under Recent Projects with that name is the file in the external drive. The “hard disk” option does not show up. The file I told you about I could once see --with “0” words and only the Trash Folder (no binder, no drafts, no notes) is no longer there at all. As I said in my private email to you (to support), it was kind of a “phantom” option in “Recent Projects” --first with the ‘Trash’ folder only, now nothing at all. Just the external drive. I am at a loss. My FEAR now is to lose my dissertation project in the same manner. I will backup every single morning and afternoon, I swear, but I still would like to understand whether I have done something wrong. For example: the fact that I always worked from the Scrivener program, and I never “saved as” in a personal folder (desktop, school folder, etc.) has anything to do with it? I should still be SOMEWHERE, which is the ultimate mystery to me. How it disappeared after the “Warning” message from Scrivener that pop up in my screen. Sorry if I am writing nonsense. Many thanks again.

hi, buenos_aires,

Fellow Scriv user here. Maybe Keith has you all sorted out and fixed up by now, but, for what it is worth, here is where my troubleshooting intuitions would go with this case:

First, it sounds to me like you had been working in the Scriv project that is on your external drive and did not realize it. This explains why the project on the external drive is listed in Recent Projects when the drive is plugged in. I am guessing also that, while that project was still open, you disconnected the external drive (because you did not realize you were actually using the file on it), and this is the root of your problem. What you typed in the project after the drive was detached could not have been saved back into it, because it had been taken off-line.

Just possibly (and here I really am just taking a shot), the basically-empty project that was showing up under Recent Projects when the external drive was not connected was a copy of the very original project file you created and which had since been dragged to the OS X system Trash. Spotlight did not find it when you looked later, because you have emptied the Trash since.

That would be my best on-the-fly armchair diagnosis from what I have heard of the case. I hope this helps. (Well, and I hope it is not really true, since it may mean you lost some work as a result.)

Best,
Greg