Please help . . .

I was just going along writing (which I had been doing for an hour or so), when I got an error that told me my changes could not be saved that the project would now be closed. I tried opening it again to the same effect. I then went to get my last backup. That says:
The project at “/Users/sea/Documents/IðunnBragi.scriv” seems to be of an older format, but no binder.scrivproj file could be found inside it. It may be missing or corrupt, possibly because of a problem with the device on which it is stored, or because of a synchronisation problem.

Try ctrl-clicking on the project in the Finder and selecting “Show Package Contents”, then look for a file entitled ‘binder.scrivproj’. Ensure it has not been renamed by a backup routine. If it does not exist, try restoring from a backup.

I have tried the last four backups. They all give this error. How do I get my work back?

I have reinstalled both Scrivener and Dropbox, then restarted, zapping the RAM, and the problem is magically fixed.