Please make Undo/Redo Keyboard Shortcuts on iOS Scrivener

I’m not sure if someone has already written about this and if they have, please direct me.

Essentially in using Scrivener for iOS with an external keyboard, I can’t seem to use the same shortcuts I usually do in Scrivener for MacOS. I understand this is to be expected as not everything can be transcribed but in using my external keyboard to type on my iPod, it would really be nice if there were a shortcut for ‘undo’ and ‘redo’. Command Z or Option Z doesn’t seem to work. Perhaps I’m missing something or there’s another way to do this.

I figured out how undo/redo – you shake the iphone/ipod and up pops a message. I find this very counterintuitive and gets in the way of my writing, as I don’t want to shake my device every time I want to undo or redo anything. It’s all a very strange and silly experience. It would make much more sense if there were a shortcut (one as well that didn’t require you accept whether you want to undo or redo on the screen itself but more or less just did it).

Please, Keith and L&L, if you can make a shortcut for undo and redo perhaps coded into iOS scrivener, that would make writing long documents a little easier.

Hm… cmd-z works on all combinations of

  • iPhone 5c
  • iPad Air 2
  • Apple Magic Keyboard
  • Logitech Ultrathin Keyboard for iPad Air 2

Further, shift-cmd-z works for Undo. OTOH, the cmd-z shortcuts don’t show up on the iPad list of keyboard shortcuts.

Very strange.

Yeah everyone else has to literally shake their device to undo or redo! It is inanely foolish! Shame on Apple. Who the heck wants to shake their device in the middle of a writing session especially when using an external keyboard thereby somewhat removed from the device itself. The action of having to pick up you device, shake it, and put it back to wherever it was pisses me off to the freaking core.

My hope is that maybe the folks at scrivener could maybe make some kind of workaround

“Shake to Undo” is an annoying “feature” of iOS that can be controlled from Settings App > General > Accessibility .

Don’t you see the undo/redo buttons at the top of your iPod screen? An interruption of keyboard flow, I grant you, but surely better than picking up the iPod and shaking it… :slight_smile:

Yes, I noticed that, but when you are working with a tiny iPod, it’s really inconvenient to have to take your finger and tap those little arrows on the top of your screen to undo/redo. A keyboard shortcut would be a godsend.

I guess you can call me finicky, but in my last writing session, I had to undo like a million times, and the whole experience was frustrating, not to mention a bit dizzying!

iOS in general hasn’t supported external keyboards well. Since the shortcut works on non-iPod devices, it’s down to your keyboard or the iPod. Also, since it’s not in the shortcut list that shows up in iPad Scrivener, it may be something that iOS handles internally for the keyboards that are made for iOS, rather than something Scrivener does. May I ask, what external keyboard are you using?

I’m using a belkin wireless keyboard model f5L175

I know its on the screen and not on the keyboard, but have you spotted the two two half-circle arrows? Counterclockwise (Left) is undo, and clockwise (Right) is redo. On the iPad they are on the bottom left of the edit window and on the iPhone/iPod Touch they are on the upper left. See the blue arrows in the images below.


A nice bit of hardware! I took a look at the specs, and of course the iPod Touch isn’t explicitly mentioned as compatible – but then, when is it ever? (Must be a painfully common situation to you :slight_smile: )

It may be that Apple, in its corporate wisdom, isn’t bothering to install all the keyboard support pieces of iOS 9 on iPods. A simple way to check that is to go to an Apple store and ask to test one of their keyboards with your iPod. If that keyboard won’t send cmd-z to your iPod, then that hypothesis is confirmed.

If that is the case, then indeed your only hope is that L&L will override the built-in cmd-z keyboard shortcut with its own – if that is even possible. I won’t pretend to know Apple’s external keyboard interface, but for a lot of apps that support external keyboards, the answer from the developers is all too often “You can’t get there from here.” :frowning:

— Another thought: try cmd-z in some other app, like Notes. Notes supports it – I just checked. If it doesn’t work, that’s more evidence in favour of the “crippled iPod” hypothesis.

Regarding them not appearing in the list of shortcuts, that’s not strange at all. Applications have to choose which shortcuts they show in the list that appears when you hold down Command - you can choose to give some a description so that they appear there, and others no description so that they don’t. Given the limited space, you wouldn’t want keyboard commands that are common across the system to appear there. Also, some keyboard commands are defined by the app, while others are defined by iOS. In general, you’ll want most of the former to appear in the shortcuts list. Keyboard shortcuts defined by iOS rarely have descriptions. In this case, Undo and Redo are defined by Apple’s text system and so do not appear in the list.

They are there, however, as you note. Cmd-Z and Shift-Cmd-Z work fine for me on both my Smart Keyboard and my Brydge Mini. (I’d love to tell you how they work on my Zagg, too, but Zagg are COMPLETELY USELESS and still haven’t shipped me the keyboard I ordered about six months ago.)

So Keith…is there nothing then I can do?

Okay, so I connected the Apple magic keyboard to the iPod, and voila, cmd-z, shift-cmd actually worked. It brought tears to my eyes! So, Keith, I take it then that it’s a hardware issue, not a software issue? Is there any way to know if a external keyboard supports shortcut undo/redo in Scrivener beyond simply purchasing it and testing it out? Sorry, your post was kinda dense and I’m not that computer-programmer-savvy.

In the meantime, I’m thinking of making some kind of magic keyboard-iPod contraption. I’ll let you guys in on what I end up designing. :frowning:

Here’s an inexpensive solution I happen to have on hand:

So essentially, in an emotional fit, I bashed my Belkin keyboard repeatedly on my table and tried to cmd-z-my-arse-off-on-it hoping high-or-hell-water it would work. Believe it or not, my uncivilized ways aided me ultimately in my endeavors, because now cmd-z suddenly began working. It’s a miracle!

It may have been the pairing of magic keyboard that jolted the ipod to start acting right…I dunno.

Bottom line, matter is resolved and I can go back hopefully to my writing. Thank you all for your assistance.

ROFL! Sometimes, these . . . things just need to be reminded who’s boss. :smiley:

Or, it might have been a connection that was just slightly out of alignment… Glad to hear you’re up and running! :slight_smile: