positioning header for PDF document

Needing help on how to position headers. The headers do not position in the middle of the upper margin. Tend to merge into body of text. In any event, I’ve tried to adjust positions of the headers in the page set panes but seems to have little effect. Any advice welcomed. Are there any key commands for moving header positions? Much thanks. Haven’t had too much trouble with other aspects of the program.

Hi, Mack, and welcome to the forum!

Would you elaborate on what do you mean by adjusting header positions? :open_mouth:

Is this the pane where you adjust your headers?

Yes, this is the pane. I’ve tried to move the headers, for example, by positioning the cursor beside the tag, holding down option, and hitting return. Have tried to manipulate the tags, e.g., <$projecttitle> in various ways, using tab, etc. in attempts to move them vertically and horizontally. I keep thinking there’s some special key strokes to get better flexibility in moving the headers around. My knowledge base involving this feature is pretty limited. Do I need to back up and punt?

I’m not sure I follow what you want to do. Each one of the six boxes specifies a position on the page. Top-left, top-centre, top-right, etc. Why would you need to move the headers if you can place any component on the exact position you want? :confused:

There isn’t much control here. You can kind of force it by adding opt-returns and such as you have been, but I wouldn’t really recommend bothering with it that way, it’s too easy to end up with overruns or awkward looking spacing. You’ll get way better control in a word processor or desktop publishing program after you compile, and in most cases you can make that adjustment only once and impact the entire document.

Better insight into the limitations and options. Thanks for the feedback. Much appreciated.

Actually, there should be a way to sort this out. The way Scrivener positions its headers and footers is this: it gets the imageable page bounds - that is, the area on the page it is allowed to print on to - and places the header halfway between that and where the text starts because of the margins. This should normally be absolutely fine, because if there is any difference between the imageable page bounds and the full size of the paper, it shouldn’t be much, just a little bleed allowed by the printer. However, if Scrivener is told that the imageable page bounds is much smaller than it should be, you can see results like you are getting.

The page boundaries are all reported by your printer (even if you are creating a PDF document, because the PDF format uses the printer mechanisms of OS X, the same as going to print something and choosing to create a PDF instead from the “PDF” button you get in all OS X print panels). I’ve seen this happen to a few users where printers are, for whatever reasons, reporting a much smaller printable area than they should be doing. So what you need to do is override your printer’s settings for this To do so:

  1. Open Page Setup. Where you do this will depend on your page settings. If you have “Use project Page Setup settings” in the Compile Page Settings pane, you’ll want to do this in File > Page Setup when Compile isn’t open; if you hadn’t haven’t ticked that checkbox, just click on the “Page Setup” button next to it in Compile.

  2. In the Page Setup panel, next to “Paper Size”, make sure the paper size you want to use is selected and make a note of the actual dimensions of the paper that are written under the pop-up button (e.g. “216 x 279mm” for “US Letter”.

  3. Now select “Manage Custom Sizes…” from the pop-up next to “Paper Size”.

  4. In the “Paper Size” text fields at the top of the pane that appears, enter the dimensions you noted down in (2).

  5. In the list on the left, give your custom paper size a meaningful name (you’ll be able to choose it from the paper sizes list in the future).

  6. Take a look at the settings under “Non-Printable Area”. That is going to be your culprit - you’ll probably see values there that explain why your header is getting pushed down. To fix it, change the “Non-Printable Area” pop-up setting to “User Defined” (you can compare it to the printers on your system that are also listed in that pop-up).

  7. Once you’ve selected “User Defined”, edit the values below to something more sensible. It should be safe to set them all to zero, so I would start by doing that - you can always tweak them later if the PDF doesn’t turn out as you wished.

  8. Once you’ve done that, hit “OK”. The paper size you just defined will now be selected in the “Paper Size” list. Ensure that’s the paper size selected for your Compile settings.

You only need to set this up once. From then on, you’ll just need to choose the custom paper size you created whenever you create a new project or change the Compile settings. The Page Setup panel is a feature of OS X’s printer interaction, not part of Scrivener, so you’ll be able to access that paper size from other applications, too.

I hope this helps - let me know if it doesn’t address the issue, though.

All the best,

Keith, I just came back on over a week later just to check posts re: my Header question. Thank you for the information. It took care of the problem. Tremendous help.

Thank you!