Possible bug in new beta?

My wordcount said that I won NaNoWriMo yesterday. It was a little bit of a surprise, because I didn’t think I had written quite so much as four thousand words in that one writing session. But I scrolled through everything to check, and couldn’t see anything that said otherwise. So I updated my wordcount on the NaNoWriMo site and decided to take a break from writing through the day today to catch up on another couple of things that I’d been neglecting. I reopened Scrivener to write some more before sleeping about ninety minutes ago and carried on writing, and when I finished chapter eight and went to add and name chapter nine, I saw that it had duplicated almost all of chapter eight without being told to. I now had two chapter eights on my file list, one of which was incomplete and which was definitely NOT displaying yesterday.

So I copied the contents of the longer one into LibreOffice just in case, deleted the shorter entry and went back to check on the longer one. It was empty. So I pasted it all back in and saved, clicked off and back into the chapter again. It had gone back to being a copy of the older, shorter version that cut out halfway through. So I deleted that too, cleared trash and remade/pasted the contents in.

However, now my wordcount comes up as 46k, not 50. Which means that I’m just barely ahead and haven['t won yet. But my NaNoWriMo wordcount is already updated. And the Scrivener wordcount, I am told, gives a far higher total than the validator. Which means that I am probably now very behind. Once I’d calmed down over the beta thing and got it working again, I thought I’d be alright continuing to use Scrivener. And I realise that when in beta, it’s going to have bugs. But all the same, it’s rather discouraging. This is the second time that Scrivener has put me behind in the same month. :frowning:

Anyway, I use OpenSuse 11.4 and the KDE desktop if that’s any help to whoever fixes bugs.

It did it again! Sort of. I’ve been going back through my novel, correcting typos and generally proof reading. I’ve -added- a few words here and there as I’ve rearranged a couple of sentences that looked a little awkward, and yet even after I caught up and re-won NaNoWriMo, compiled what I had and then -verified- it, it’s now telling me that I have just under 47k. There’s no WAY that rearranging a couple of sentences removed almost 4k words. Something is very wrong with this program. Or this version of it, anyway. :frowning:

My compiled file from last night pasted into Libreoffice says… 52569 words… Scrivener currently says 46805. And I just discovered that it ate the first half of Chapter three this time. I had only proof read so far up to the end of chapter one. Sigh.

Scratch that. It’s gone back to old versions of the files. Which means I’ve probably lost a good week of work. -.-


Make that a month’s. All but three chapters have completely vanished, and one of those is incomplete. If my friend hadn’t asked for a PDF to read what I had so far, and I hadn’t made that last night, I would have lost the lot. I realise that beta stages are going to have a certain amount of bugs. But something that deletes this much work is inexcusable in my opinion. I now have to spend time I don’t have trying to recover and edit what I have, and searching for new software. Because I probably won’t be using Scrivener again. It looks good, and the features are decent when they work. But I’m not prepared to risk losing this much work again. It’s just not worth it.

First off, congratulations on getting over 50K despite setbacks! That’s a big win.

Second, I’m quite sorry about the difficulties you’re having! This is a complete new one–or two–so any additional details, as much step-by-step through what you did and when and how you noticed what was missing, etc. would really help, as I haven’t even seen other reports on random duplication or individual binder items reverting to older versions, and I haven no idea on the face of it how that could happen. Each document in the binder is stored as an individual RTF file, which is continually updated when you make changes, so there aren’t older versions of the file lingering around within the project. For these files that reverted, had you made changes to them, closed the project, reopened, and seen the changes were still there at some point? Are the items still listed in the binder and just coming up blank in the editor, or are they not in the binder at all? Did you happen to have older snapshots of them corresponding to where they’ve reverted to?

Have you tried searching for the missing text in the project directory directly, i.e. if the RTF files are contained in the project but not displaying correctly in Scrivener? If the .scrivx file got messed up, it wouldn’t show all the documents that should be in the binder, but the files themselves would still be in the project, just unrecognized. Do you do you run any kind of sync service on your project folder (or more likely the directory where your project is store) or have you moved the project around on your drive or to another computer?

Where are you checking in Scrivener for your wordcount? You can get differences depending where you’re looking; the editor footer and Project Targets will just count everything displayed in the editor, whereas Project Statistics will go by your actual compile settings. In general I think a lot of people were getting a lower word count in the validator than in Scrivener, but actually I’ve seen a number of users (myself included) who got a higher count from the NaNo robots, so it’s really all relative and based on what punctuation and symbols and such you use in the text–which you’ll see going from program to program anyhow. (Word, for example, counts " * * * " as three words.) I realize that the main problem here is that apparently text was actually appearing or disappearing in your project, but its worth knowing the differences in the counts anyway and that it may not be so bleak, the difference between Scrivener and the NaNo count.

The word counts have always been off compared to Libre Office, I’ve found. It’s not necessarily a missing thing, as MimeticMouton mentioned.

For instance Scrivener reports one thing I’m working on at 14,738 words while Libre Office says it’s 15,148.

KDE user here, with Slackware, and I haven’t had the problems you’ve had with it duplicating content. Did you accidentally duplicate a section? Did you back up to zip and then open the backup? That’s known to cause loss of text, if you don’t delete all the 0-sized files first.

Thanks. :slight_smile:

It was just one file that was (partially) duplicated rather than a whole folder. And I think only one (different) file had text deleted. When I found the missing text in Chapter three, I stopped looking for missing text and started to look for possible explanations and solutions, so there could have been other parts missing further down the chapter list. I hadn’t opened that chapter since writing it. I did check the folder it was all meant to be saved in, but couldn’t find any other versions of the file that had been affected. I don’t sync with anything, I just backup every week or two to an external harddrive through a regular USB cable, and previously to the text being eaten, I had not plugged it in for a good week. I usually use project statistics, but when the eighth chapter was duplicated, I did check it against project targets and text statistics from the same menu.

Scrivener gave me a total of something like 50700 before the duplication, and about 52500 before the deletion. So I know it isn’t down to that. Word counters may differ sometimes, but not by 4-6 thousand words. Libreoffice was showed a difference of -18 words when I checked before the text was eaten. And I could see exactly which chunks of text were missing by comparing previously compiled versions. I’m 99.9% sure that nothing was duplicated by me accidentally. And I haven’t heard of any zipping bug, but I didn’t zip anything. I just copied and pasted the whole NaNoWriMo folder from one drive to the other. Here is exactly what happened, as posted on the NaNoWriMo forums. Sorry it’s so long:

Someone on that forum asked if I used Dropbox or anything Cloud-based, and I don’t. Is there anything else you need to know?

Sorry for the double post again, but I just started copying and pasting the compiled PDF into another program and the compiling process has also doubled up on some lines. I’m guessing it’s on page breaks. The distance looks about right for that. It won’t have affected the word count that I thought I had, since I verified by copying and pasting from Scrivener itself before it ate any text. But it’s another bug, so I thought it should be mentioned.

Hrm. I’m wondering if Lee can give us an updated list of dependencies. Last one I saw was a year ago, with the first linux compile. There might be some issue with whatever library LInux Scriv uses for text munging that’s different from the Windows/WINE one.

I don’t think it’s a Qt/KDE thing, since I’m using KDE, myself. Plus Scrivener uses it’s own Qt libs, so it shouldn’t be considering the system ones, unless something was linked wrong.

Glaedr - Hmm, okay. So with the duplication and text missing issues, did that happen within the file? Meaning, did you get a full duplicate “Chapter 3” file appearing in the binder or was the text within that file duplicated in the editor? Likewise for the missing text, reverting to older versions as it appears, that was just in the editor–you should’ve had two paragraphs, but instead you had one, that sort of thing, vs. the documents not appearing in the binder at all?

Thanks for the note about Dropbox/sync. Sort of a bummer in a way since it might’ve been possible to trace through older versions of the file through that, but good to know that it’s not a cause of whatever happened with the files. I’m afraid I’m still at a complete loss as to what happened, though, but I have ensured Lee’s aware of this. We’re also in the process of getting an updated Linux build out, based on the 1.0.3 Windows version, so once that’s available I recommend updating if you do decide to use Scrivener in future (I know you may not be, which is fine also of course), as there were several bug fixes dealing with how files in the project get flagged and that may address this issue.

Regarding the doubled sentences in compile, did you mean that the compiled doc shows duplicate text and the project does not, or is it in the project as well? You say it’s likely at page breaks–is that every page break in the PDF or just the “set” page breaks, i.e. ones that would be specifically placed between sections because of the Separators setting or from having ticked “page break before”?

Garpu - I’ll ask Lee about the dependencies and see what he can do.

Thanks for the reply and for passing it all on.

The duplicated chapter was the eighth. The word counters all said Id passed 50k without the project showing any duplications, until Scrivener was restarted the next day, when the duplicate chapter appeared in the file list. It wasn’t a full chapter, but contained maybe the first two thirds of it.

Chapter three was the one that had text eaten - probably about the first half of that chapter vanished, though bizarrely it kept the first two lines above the second half where I’d written in a header. This one was not affected in the file list as far as I remember.

The doubled sentences did not appear in the project files, just in the compiled PDF. Unfortunately I don’t have any older compiled files now to compare it to, so I don’t know if it did it every time or not. The page breaks thing was a guess really, as it didn’t happen to every line and the spacing between them seemed fairly regular and about the right size. Though now that I look at the PDF it doesn’t display them… though they all doubled up when I copied and pasted into a basic word processor in order to proof read everything. So perhaps that issue is with my PDF reader instead. I’ve never noticed it before however. It doesn’t like copying word wraps either, or the double spacing on new paragraphs. I might try a different PDF reader and see if that makes a difference.

Quick update. - I’ve been doing some more editing on Chapter 2, and I just found a random line from a few pages back inserted into a later paragraph. I haven’t read through anything in full yet. - I’m still fixing the line breaks. But I’ll let you know if I find any others when I do.

Was this editing you were doing in Scrivener or off the compiled PDF?

The editing itself is being done in another program called Storybook which I downloaded after Scrivener ate my files. But the random inserted line and the duplicated lines were in a block of text copied and pasted directly from the compiled PDF. I hadn’t saved anything yet, and it doesn’t -display- duplicate lines there, but it does paste the same into other word processing applications. I haven’t found any other random lines yet, but the duplicate lines run through the whole thing.

Maybe Scrivener clashes with OpenSuse? Does anyone else here use it?

EDIT: Just looked for a particular duplicated line, and it is indeed on a line break. It’s the last line on the PDF page.

Since I had a spare thirty minutes while waiting for my baking to finish, I tried re-installing and pasting my now duplicate-line-deducted text back into Scrivener chapter files. It now says that I have 49,493 words. Which makes me wonder if the duplicate lines were somehow saved in the novel file and just didn’t display at the time. Though the non-PDF I compiled earlier on didn’t have any duplicated lines in it. I’ve also just tried re-compiling into another PDF twice. And neither of the new ones have any duplicated lines. I’ve tried ebook>PDF and custom>PDF so far. Perhaps something went wrong during the installation of the forced update? :confused: I haven’t downloaded or deleted any dependency files for anything recently as far as I can remember.

Edit: Sorry, scratch the wordcount thing. I missed a bit while pasting back in.