Possible bug in Script Settings window

The other day I went into Format> Scriptwriting> Script Settings to make a change to my screenplay and things really went haywire like I’ve never seen in Scrivener before. Under Scene Headings, I went into Fonts and selected Bold. Once I actually made the change, rather than bold my scene headings, Scrivener instead selected every Action block of text and capitalized and bolded it. When I clicked on these paragraphs, I discovered that they had all been changed from Action to Scene Heading, and the actual Scene Headings, which were not bolded, had been changed to Shots. Anticipating your question, when I went to make the changes, another window came up. It said Convert From Current - Screenplay, Convert To Current - Screenplay. It then listed two columns, Elements and Convert To, which listed the various types of elements. In those columns Scene Heading, Action, and Shot were all lined up correctly. I had not inadvertently selected to change Action to Scene Heading.

After this happened, I opened my last backup and saved it as two different versions, labelled A and B. I tried the process again on file B, and the same thing happened again. Tres bizarre!

Have you ever seen this before? Did I do something wrong? Do I have a corrupted file?

Comme c’est bizarre. In the interests of science, in your backup copy A (before you change the settings), if you click in the document on a scene heading, is it labeled as a scene heading appropriately? Likewise for action. Just to rule out the idea that the confusion is there and not something occurring in the settings dialogue.

Yes, that’s correct. The Scene Headings are showing up as Scene Headings, the Action as Action. It’s only after I make a change to the settings that they get changed to something else.

Very odd - I cannot reproduce this at all. Could you please send a sample project (zipped up) that exhibits the problem to kb-tech-support@literatureandlatte.com?


All the best,

Sure, Keith. Just emailed it to you. Thanks for looking into it.

Thanks! I’ll look at it tomorrow (it’s nearly 10pm here and thus time for Castle and wine) and let you know what I find.
All the best,

I’ve looked at the file and I can’t see anything remiss in what Scrivener is doing - the problem seems to be down to how your script is formatted. All the elements that have been embolded are scene heading elements - it’s just that you seem to have scene heading elements where normally there are action elements (this is what MimeticMouton was saying to check in her earlier post). Likewise the elements that would normally be scene headings are “Shot” elements in your project. If you click into each element and check the pop-up button in the bottom-right of the footer bar which identifies the elements, you’ll see what I mean.

You can convert the elements using Documents > Convert > Script Format… but this won’t help with changing the action elements back to lowercase.

Did you import these scripts at all, or were they all written in Scrivener? Did you make any other edits to the script settings along the way?

All the best,

Yes, I get that the Action sections really are now Scene Headings and the Scene Headings really are Shots. There’s no doubt about that. But they weren’t that way until I clicked “Okay” on my change in Script Settings, which didn’t involve any changes to Shots or Action or anything else. I changed one thing and one thing only, which was under Scene Headings> Fonts> I checked the box to make them Bold. That’s it. Then I clicked okay, saw the warning about can’t undo, clicked okay again and - prest-o change-o, I ended up with the document you see before you.

The entire document was written in Scrivener. I haven’t worked on this particular project in several months, in fact I believe this is the first time I’ve worked on it since upgrading (I’m currently 2.0.5), so maybe that had something to do with it or perhaps the file just got corrupted. I was able to do open a backup and do a save as and the current file seems okay, so I’m just going to keep working and hope it doesn’t happen again. I was mainly wanting to alert you just in case it is a bug and it happens to anyone else. Thanks for taking a look.

Ah, right, sorry, my misunderstanding. I think the 1.x -> 2.0 thing may be an issue. There were some issues with script settings not being recognised correctly between 1.x and 2.0, although these have now been ironed out (or should have been). However, if you upgraded this project with a version of 2.0 prior to 2.0.2 (off the top of my head - it might have been prior to 2.0.3), then some of the formatting may have been recognised wrongly. Could that be the case?

Thanks and all the best,