Praises & a question..

I´m new to Scrivener.
I´m also blown-away.
Wonderful little software it is. It has totally changed my workflow all over.
I use Scrivener for such broad tasks as novelwriting, radioprograming and screenplays.

Scrivener has made me leave both Montage & Word behind… not ot mention all those yellow sticky little pappernotes…

Now, the question…

When in Screenplay mode (works verry well, thank you) I have encountered something pretty irritating, and it´s when Scrivener auto-fills names for a charachter.

If I have a character named ALEX, and I write Alex´s car,
that (Alex´s car) will then pop up in the characterlist (in the actual document - not in the Binder Charcter list) as a suggestion for a character…

What am I doing wrong? I know it´s me… Scrivener is flawless.

Hi Aribus,

Many thanks for the kind words, much appreciated.

I’m not sure I entirely understand - do you mean that when you go to type “Alex”, the auto-correct suggestions “Alex’s car”? If so, did you ever write “Alex’s Car” in the character area at all by mistake? Try going to Project > Auto-Complete List and see if “Alex’s Car” is in there. If so, delete it. That allows you to add or edit anything in the project auto-complete list.

Hope that helps, but let me know if not.

Thanks again and all the best,

No. I don´t think I wrote it like that.
I now have three diffrent Alex as character suggestions, Alex, Alex´s Car, & Alex´s Bedroom.
I´ve heard it´s the next big thing anyway…

I´ll try what you suggest. Just what I was looking for.


Ah, wait, I bet you wrote them as part of the location in the scene heading, right? Because Scrivener isn’t a dedicated screenwriting app, it doesn’t have separate auto-suggestions for each script element type, but rather a single pool of auto-completions for the whole project. By default, both the scene heading and character elements are set up to add anything entered in them into the auto-complete list, so that would explain what you are seeing. If you want, you can prevent scene headings from adding anything to the auto-complete list by going to Formatting > Scriptwriting > Script Settings, selecting “Scene Heading”, clicking on “Auto-Complete” and then deselecting “Automatically add phrases to project list…”.

All the best,