Preferences don't "take"

I am making changes in preferences – this time eliminating “auto-correct” for script mode – but the changes do not have any effect. Quitting/relaunching the app makes no difference; preference remains ignored no matter what.

What gives? Mac v2.0.2
-Vb

Do you mean that if you de-select the checkbox, when you restart Scrivener the checkbox is on again? If so, you might have a corrupted preference file. I’d follow these instructions for resetting:

  1. Go to the main preferences panel in Scrivener and use the Manage... drop-down menu to backup a copy of your preferences to the desktop

  2. Close Scrivener

  3. Navigate to your Library/Preferences folder and move these two files to the desktop:

    • com.literatureandlatte.scrivener2.plist
    • com.literatureandlatte.scrivener2.LSSharedFileList.plist
  4. Launch Scrivener again

  5. Insert your name and registration details

  6. Use the Manage... drop-down to load your preferences from the desktop backup file

If on the other hand you mean the checkbox doesn’t seem to do anything, let us know what behaviour you are seeing in the editor with as much detail as possible, and what you expected the preference to do.

Are you out of storage space on your hard drive? If so, your system won’t save preferences.

Well it’s working now. Sorry, false call!

  • Changed the setting, tried it and failed…
  • Quit app, restarted/opened, tried it and failed…
  • Posted question, kept working…
    then noticed that it was now working (no auto-correct in script mode).
    Not sure what happened, but glad to plead user error/gun jump.

I’ll remember your tips if it happens again tho…Thanks!
-Vb

AHA!
Found the problem: Scrivener is “slipping out of” Script mode every now and then.

I noticed this a while back when certain keyboard screenwriting keyboard shortcuts stopped working (i.e., tab to next correct script style), even while in the middle of a script-formatted page. I have been dealing with this by hitting Cmnd-8, which usually snaps everything back to normal.

So: changing my prefs to disable auto corrections while in script mode is what was failing. Deselecting the two most annoying (three periods to elipses, two dashes to em dash) globally is what actually “solved” the problem. But the larger problem remains, i.e., keeping Scrivener locked into screenwriting mode only, full-time, without any unwanted “drop-outs.”

Any thoughts?

Most likely, you are just accidentally hitting the Cmd-8 shortcut. If you write a lot of footnotes and/or comments, it’s not unlikely to accidentally press too lightly on one of the modifiers and end up toggling script mode. I’ve never seen Scrivener spontaneously switch modes without any input, though, there is a first for everything.

It’s also the case that when you create a new document, Scrivener uses whichever mode your previously loaded (and in-focus) document was in. So if you happened to be viewing a research document or another part of your project that wasn’t in script mode and then created a new document, it would not be in script mode. You can get a quick visual by checking the icon–it should be yellow with three “hole punches” down the left side–or the footer, which will display script elements when in that mode.

Yes, script mode is per-document - it’s not a global setting for the project. If you enter script mode, it puts the current text document in script mode, but if you select another text document that wasn’t in script mode, it still won’t be in script mode.

Nope, no accidental cmnd-8, and not happening (only) with new pages. I notice that when creating new pages, no problem to change modes and keep working.

What happens is, while in a script page, already formatted, mid-edit, suddenly the keyboard shortcuts stop working. Now that I know what’s going on, I hit cmnd-8, everything shifts slightly upward, and Scrivener snaps back to normal scriptwriting behavior.

Later on, same thing.

?

Do you use Scrivenings mode frequently, and if so, do you often end up with script and general text in the same session? Scrivenings mode will choose input mode based on the ratio of included items. So if they are mostly general texts, you won’t get a scripting interface (even though the underlying files are still fine) and vice versa. When you use Cmd-8 in a Scrivenings session, it just changes the mode for the session not the underlying files—this way you can work with multiple document modes and toggle back and forth as needed.