Preferences not 'staying put'

More apologies but this picks up a bit on my earlier question from a few weeks ago, or is related, and I’m stumped after trial and error: regarding both formatting preferences and project formatting preferences:

No matter what I do, I can’t seem to get the formatting preset button to give me the formatting I want. I’m sure I’m missing something painfully obvious, but either in the general preferences or in project formatting preferences, for some reason I can’t get the results (e.g. toggling “body” text) to retain what I think I’m setting up in the preferences. I set the “body” text for Helvetica 12 non-bold with a bit more line spacing (1.1) in Preferences. When I open a new project, what I find is that the first text that appears in a document seems to be a Heading text for some reason; if I toggle for “body” text, I keep getting Helvetica bold, 1.0. No matter how much I change things, I get this. Same happens if I go to Project/text preferences and click override and try to set it. What’s the key step I’m missing in getting this to “stick”? I click “okay” or “make default” or “use current” in the window (all hapless trial and error) but when I click on “body” in the document, I still get the old bolded font and so on.

Anybody catch what I’m missing? Thanks a zillion. G

It sounds like you’re trying to format the presets from the Preferences pane, which is not how they work. The Formatting tab in Preferences is for setting the default formatting for new documents; when you select a preset from the format bar there, you’re just applying that formatting to the sample text so that you can use it as the new document default. To change a formatting preset, close Preferences and format some text the way you want it in the editor, then select it and go to Format > Formatting > Redefine Preset from Selection and then choose the preset you want to update. You can also create new presets or delete existing ones from here.

You’re not the first who’s stumbled on this, so in the next version the format preset button has been removed from the format bar in the preferences to help reduce confusion (though it is still possible to apply preset formatting to the preference text using the menu, so the feature itself still exists).

Wow! That works! Thanks for your help.

I agree that this is a pretty well hidden place for this, with a bunch of what psychologically seem like “decoy dead ends” that the average trial and error scrivener might exhaust him- or herself on to find this. Generally, setting “styles” seems hard to do easily in a lot of softwares, and it can be hard to even figure out what terms to search for in manuals and such to figure it out.

Thanks again.