Prefix/Postfix for inline annotations stopped working

Dear all,
yesterday I upgraded to the most recent version of scrivener for windows 1.5.x. I am writing in MMD which I export to LaTeX. With the previous version of scrivener 1.2.x I was able to export inline annotations with pre- and postfixes. I used these to get LaTeX style annotations with fxnote.

So I set my prefix to:
and my postfix to:

Then all annotations became nice latex annotations (\fxnote{inline annotation}) with all its comfort. However, this is no longer working with 1.5. The pre- and postfixes do not seem to get exported to MMD/Latex. No trace of them in the latex output :frowning:

Any hints and help would be much appreciated!

Best regards

Robert Hilbrich

Have you double-checked the settings in the Comments/Footnotes compile option panel? I just did a test run using the exact same setup you described, to both plain MMD and .tex formats, and both worked fine. However, I’m wondering if that in the change to supporting the new linked comment feature, the compile settings you’ve been using have been lost for this panel, since things were switched around. There are now two checkboxes here instead of just one (which is very handy for actual notes. I use inline annotations like you do in some documents: as functional syntax. With the new system you can omit sidebar comments but leave inline ones going).

I am sorry, but I still do not seem to get it working. I attached several screenshots of my scrivener Text, my compile settings and the respective latex output …

I am not using the “memoir” template for latex, but my own headers which are imported by using the “None/Custom Meta-Data” setting (see attached figures).

Did you do anything different? Everything worked fine in 1.2.5 … :S

Here is


The line 1603 in the LaTeX Output should have an \fxnote{…, but it doesnt …

Best regards,


Thank you for the additional information! I unfortunately still cannot reproduce this on my end. I have set up a test project with as many of your compile settings as possible, and when compiling either an .mmd file or a .tex file, I get the inline annotations output as directed. I did spot one other bug with them that needs to be fixed, but they are at least there.

I’m wondering, can you achieve the same results starting with a new blank test project? If so, could you send me the steps it took to get that test project to fail?

Nope, I started with a “blank” project - no luck. No annotation gets printed out. I am going to uninstall scrivener and reinstall from scratch. Maybe something went wrong after the update …

Here is the example project which does not work here … (8.7 KB)

I did a clean re-install of scrivener and now it works fine…
Maybe something with the update screwed up the configuration or libraries …

Thank you for your help - I really appreciate it!

Best regards,


That’s very strange that such a simple feature would be impacted by a re-install, but I’m glad that did the trick. :slight_smile:

I can confirm that the currently downloadable version of Scrivener does not export the prefix/postfix enclosing markers for inline annotations.

I’ve just downgraded back to the initial version of (as mentioned here: [url]]), here I get the expected results for inline annotations.