Preserve Formatting problem

I have some short sections of a screenplay inset into my vanilla manuscript. The screenplay has its own font and narrower margins as a style. I used Preserve Formatting on this section, but it looks different after compile than I was expecting.

The font for the main text is the same in both editor and compile. Not sure what I’m doing wrong.

What format are you compiling to?

If ePub, this post might help:

literatureandlatte.com/foru … 37#p255637

If to another format, what paper / document size are your compiling to?

Slàinte mhòr.

This is outputting to PDF. Default paper size, which for me is US Letter with 1" margins. I don’t think I’ve changed anything much on the Page Settings in Compile for PDF.

The second and third blocks of text in the sample project attached have been formatted to different indents. Output to a US-Letter-sized PDF, only the first one has a clear right indent. I think you just need to adjust your indents, as your current 5-inch column is too wide when output: 8.5-inch-wide paper and two 1-inch margins leave just 6 inches for the body text, meaning that the right indent barely registers, especially when the left indent is 1.5 inches.

Slàinte mhòr.

US Letter.zip (96.5 KB)

US Letter.pdf (63.8 KB)

You’re right, narrowing the right indent fixes the problem.

I know Scrivener isn’t intended as WYSIWYG, but it confuses me that my page setup and font in the Editor is the same as for the PDF, yet the Editor looks lopsided and the PDF looks good. Meaning I had to futz with multiple compiles to get the look I wanted.

This makes me think I have something set wrong somewhere (rather than blaming Scrivener), but I can live with this solution.

CMD OPT SHIFT P (page view) might help.

Slàinte mhòr.

I’ve found that when I use “preserve formatting” what I’ve done is tell Scrivener “I want this text right here to be WYSIWYG.” There’s almost always a problem when it comes to compile time, because compile adjusts everything in the surrounding text, but CAN’T adjust the preserve formatting block.

I find preserve formatting a pain to use and avoid it wherever possible. In this case I’d just use a style for the screenplay chunks, making sure it includes ALL formatting. If needed I’d copy the style to my compile format to make sure that it stayed the way I wanted it in all outputs.

Of course, your mileage may vary :smiley:

1 Like

@SILVERDRAGON, I will put styles in compile on my list of things to learn. Probably the better way, as you say. Still feeling my way around Scrivener. Thanks for the suggestion.

@ JoRo, I don’t know how I missed Page View, but I love it. Thanks for that. I can’t improve much on your 85% G&B cookies…unless you’ve not yet tried them made with browned butter. That is a life- (and waistline-) changing experience.

I agree with Silverdragon, styles are a boon in many output scenarios.

Page View provides a rough guide at best, especially as the final output might have different font settings, add in titles, headers, and footers, and compile to different paper sizes — or even to formats that don’t have a fixed physical size at all. But still useful, even with all those caveats.

I have a sweet tooth. Very sweet. Browned sugar sounds mighty tempting. Perhaps I should set my avatar to a cookie and ask the mods to change my user name to Cookie as well.

Good luck with your book.

Slàinte mhòr.

Just to add another avenue to explore…

Isn’t this exactly the sort of situation where Scrivener 3’s Section Type feature comes into its own? Basically, you write the screenplay inserts as separate documents (chunks…) in the binder, then give them their own section type so compile can deal with them separately.

Takes a small amount of initial setting up to get right, but after that all you’re doing is choosing which chunks are Screenplay and the rest is automatic.

All I’ve done with the screenshot below is:

  1. Write the ‘screenplay inserts’ as separate documents in the binder using ‘screenwriting mode’ interspersed with the normal scene/section text documents.

  2. Create a new section type called ScreenPlay in the editor (in Project Settings) and allocate it to the screenplay inserts.

  3. In Compile, Duplicate and Edit the Manuscript (Times) format (only an example, I could have chose most of them). Create a new Section Layout called Screenplay. Make sure it doesn’t have any titles, and change the font to ‘Courier Prime’.

  4. On the main compile screen, choose Assign Section Layouts, then assign the ScreenPlay SectionType to use the ScreenPlay Section Layout (and the normal text to use Section, in this example).

  5. Compile.

That’s it. This gave me:

You can see the indents have come through as required and I didn’t have to change them at all anywhere.

This is the setup in Scrivener:

Obviously you’ll have to do more tweaking to get it exactly the way you want it (eg the format of the ordinary text, which is in the example based on the Manuscript format), but in principle, does this miss out anything you need?

Bravo, Brookter! much better than my solution. I’ve been known to complicate things unnecessarily on occasion. :smiley:

@ Brookter I thought about doing a Section Type but couldn’t figure out one aspect. In the screenplay parts, I want the margins narrower with the character names centered in that narrow column, but the dialogue left justified.

The only way I could figure to get centered character names would be to make the character name the title of the section, but then in the Binder I’d have one document for each line of dialogue, and that would be too much. But I might be wrong on that, and if you can think of a way, do let me know. Section Layouts would be fine for me, since I have a few screenplay bits throughout the book.

@JoRo Brown sugar, yes, definitely. But browned butter, that’s the magic.

The fug of a Sunday morning mixed with an addled brain. Beurre noisett. Must try that when I next bake. Thanks for the tip.

Slàinte mhòr.

Silverdragon and Brookter are both right.

Preserve formatting. Styles. Section types. Myriads of other options and tweaks. They’re all paths that lead to the same destination.

Magnificent to have choice.

Many of the questions on the forum have so many possible solutions that a single comprehensive answer might be a mini-manual in itself. And even overwhelm?

Simplest solution in this case is, perhaps, to adjust the indents: indent question in, indent answer out. Simplest might not be the best. And other people might yet think that other solutions are more simple still; let alone better. Alack bears alas. Conundrums heap upon conundrums. And I herd Scrivener’s cats. And then I wade.

Slàinte mhòr.

Ah, ok – I was assuming you were using the full range of typical screenplay formatting (ie action / general etc).

Section types are still the way to go, I think (it’s just conceptually simpler to have them as a separate ‘thing’ so you can see them all together as a scrivening). But you don’t have to use Scrivener’s in-built scriptwriting features – they are only a specialist subset of clever styles after all, so there’s no reason why you can’t fake them.

So how about this:

a) create a dummy script document (cmd-8) with character and dialogue to give you an easy basis to copy. Then turn script mode back off (cmd-8). The Character and Dialogue elements will retain their formatting but you’ll see that they’re now ‘no style’.

b) Make sure the ruler’s on (cmd-r) then click on the character line and then drag the centred tab in the ruler till you’re happy with it.

c) click in the dialogue line and do the same with the indents for that - I imagine you’ll be dragging it a bit to the left.

d) compile until it’s exactly how this dummy section type is how you want it.

e) When you’re happy, bring up the Style panel (ctl-s), click in the Character line and 'create new style from selection. Then do the same for the Dialogue line and create a new style for it. You can now recreate those elements just by applying your new styles.

It will take a bit of trial and error, but that’s how I’d do it, anyway… and once you’ve done it once it’s always available. HTH.

Gah! Scrivener might be beyond my ken. It’s certainly beyond my barbie. And I have barbie brain today.

My efforts have resulted in a change from TimesR to Courier in my screenplay bits, but the indents remain stubbornly unchanged. Here’s where I am at present:

  • In Editor, my screenplay bits have two styles. One for character name, one for dialogue. The styles include indent and font information. The right indent is steep.
  • I created a Section Type called Screenplay.
  • I segregated the screenplay bits into their own documents and assigned them with Screenplay Section Type.
  • In Compile, I created a new Section Layout but I don’t remember what it was based on. This might be a problem.
  • I mapped the Screenplay Section Type to my new Screenplay Section Layout.
  • I changed Section Layout Font Determined By to “Determined by Section Layout” (and Courier finally appeared in output).
  • In Edit Section Layout, I added the two Styles I used in the Editor.
  • In Edit Section Layout for Screenplay, I’ve ticked the Text box only.

And now I’m lost. I’ve tried compiling with the box ticked and not ticked for Override Text, but I don’t see a difference. In PDF output, the indent on the left seems too severe and the one on the right is non existent.

Clearly I’ve done something wrong. Anything obvious jump out?

Also, any recommendations on image hosting for screenshots? They take too much time for me to create and post, so I know there is a better way.

I did try Brookter’s suggestion with Command 8, but my formatting didn’t change. It stayed No Style either way. So I’m not doing that right either. Where’s the chocolate?!

Forgive me, I seem to have confused matters by mentioning Script Mode (cmd-8) – I thought you’d been using it, which would have been a shortcut to defining your new Character and Dialogue styles. As you weren’t, it was irrelevant.

Otherwise, it seems to me that you’re adding too many steps here, and I think that’s what’s causing the problems. I’ll go through the steps again, starting from scratch to try to make amends…

Firstly, create the Screenplay Section Layout and allocate it to the right documents as you did before. Don’t use cmd-8 at any stage!

Then create the styles for the Character and Dialogue elements. To do this, click in each one and use the Ruler (or Format > Paragraph > Tabs and Indents) to get it to look how you’ll want it. Remember, the left hand edge of the editor is the same as the left hand edge of the text in the pdf, not the edge of the page, so if you want the dialogue to start at 1" in from the ‘normal’ text, you need to set Left Indent to 1", not 2". Set the right edge appropriately (standard screenplay format is for dialogue of 3.5" width so you’d set Right to 4.5").

Create the styles from both Character and Dialogue (Format > Styles > New Style from Selection, making sure you choose Save All Formatting and tick both ‘Include boxes’.

Once you’ve created the styles, apply them to each character and dialogue element.

Then move to compile. We’re going to compile to PDF, using the Modern format as a base (starting again from scratch to simplify things).

  1. Click compile, and choose PDF from the drop down box at the top.

  2. Right click on Modern and choose Duplicate and Edit.

  3. In the new Dialogue, click on Section Layouts on the left, then highlight Section Text in the list of layouts. Now click the + button to add a new Layout. Call it Screenplay. Make sure only the Text box is ticked on this row.

  4. With Screenplay still highlighted, click on the dummy text box and right-click for Font > Show Fonts and choose Courier or whatever. Leave the ‘Override Text and Notes formatting’ ticked.

  5. Click on the Settings tab and make sure ‘Do Not Change’ is selected.

  6. On the left hand list, click ‘Separators’, then on Screenplay. Make sure that 'Use Default Separators is unticked, and make sure both Separators before Sections and Separators Between Sections is set to Single Return.

  7. Click Save to return to the main dialogue. Make sure ‘Font’ is set to ‘Determined by Section Layout’ at the top, then click ‘Assign Section Layouts’.

  8. In the new dialogue, click on Section (or whatever you’ve called your ‘normal’ scenes) and then scroll down and click on the Section Text layout. Then click on Screenplay and choose your new Screenplay Section Layout.

  9. If you’ve got other section types, then give them a Section Layout as well, otherwise click on OK.

  10. Click on Compile.

That’s all I had to do — no need to touch styles in the compile dialogue at all (Scrivener just assumes that if you’ve got a style in the editor you’ll want it in the output. You can override it if you want, but you don’t have to.)

I hope this helps and apologies for any confusion over the script mode…

Success, at last!

Things worked fine using a copy of Modern as per your instructions.

I made corrections to the Times format I’d been using with the problems. I deleted my old Section Layout for Screenplay and made a new one based on something that looked texty. I deleted the two Styles I’d added in Compile, and changed two of my separator settings to match yours. Otherwise, the rest of my changes were the same as yours.

So I’m not sure what was wrong with what I had, but now it’s right.

Thanks so much for your patience and the detailed instructions!

I had it in my head that one couldn’t mix and match novel and script functions, so I’ve never messed with script mode. I wanted the screenplay format for a few character reveries in a novel. Doubt I’ll ever graduate to actual screenplays. But good to know about.

Thanks so much to all who helped me on this.

Glad it worked!