Pressing ESC doesn't escape full screen but does a command

Hey guys,
Just have a little nit picking issue with the program.
Logically, if I’m in fullscreen mode, I expect to escape fullscreen mode when I press ESC. Instead it does a command as if I’m trying to spell something and tries to put a 1 next to whatever word I’m on in my script. I think this has something to do with auto completion (even though it’s off).

Please make ESC escape fullscreen. It breaks the flow of writing by having to drag, wait for the Maximize tab to show up, and click it. rather than pressing escape to get out of fullscreen. I know that seems minor, but all these little things add up in regards to time. Lots of programs have this logic, I think this was overlooked.


If you’re talking about Scrivener’s composition mode (rather than the Mac OS X Full Screen mode), you can enable this in the preferences under “Compose”.

No. I mean actual fullscreen. I don’t use composition mode. Still good to know if I ever end up using composition mode.

Ah, okay. I had tried using Escape to switch out of FS in a few other apps and it did nothing, so I thought you might’ve meant Composition mode. I don’t use a lot of Apple apps, though, so that’s probably the distinction–I saw it did work in Safari. Anyway, have you tried using the Ctrl-Cmd-F shortcut? That will toggle you in and out of Full Screen and is much faster than the mousing.

Oh yeah, for sure. But I’m just making a suggestion about the escape key incase it’s a possible bug. I don’t see any reason for the program to interpret it as me trying to write using the escape key (it pulls up auto-completion). It’s just common logic to escape full screen with esc.

Sadly this seems to be a “feature”(?) of Yosemite. If you want to see it in another app, try escaping out of an accidental PDF annotation in Preview. Bl**dy pain in the proverbial! I hadn’t actually come across it in Scrivener until you mentioned it.

You can take control …


That’s close to a solution. Thanks!