Printing Document Names

I’m using Scrivener to research and write an academic paper. Just sketching out the main threads I’ll be exploring I already have close to 200 named documents in the Binder.

Can I print a list of those documents, just their names? I presume I can, but how?


If talking about documents in the draft/manuscript portion of the binder…

In File > Compile, set Format As to one of the outline choices (Outliner or Enumerated Outline) and compile the project.

If talking about all documents in the project…

Switch edit window to outliner mode/view. Do this first, to avoid Scrivener attempting to build a “scrivenings” (combined) view of the contents of all the documents in the project… which would take a looonnnnngggg time.

In the binder, select something (probably anything, but a high level folder may be best), then do an Edit > Select All to select everything in the binder, i.e. in the project. There may be a delay while it works on this. You should then see all binder/project items displayed in the editor outlining view.

Click on something (probably anything, but first may be best) in the editor outlining view. This is so the needed export option will be available in the next step.

File > Export > Outliner Contents as CSV
(i.e. comma separated values, readable by Excel and OpenOffice spreadsheet apps)
Supply a location and name for the export file.

Open the resulting exported CSV file in a spreadsheet app… to see/use the document names.

I suspect there is a better more elegant way to do this… but that’s all I’ve got for now.

Select whatever you want in the binder (expand folders to select sub-documents…ALT+CLICK to open all sub-folders at the same time). If you want everything in the binder, expand all the folders and just press CMD+A.

(1) Select whatever docs you want
(2) CMD+C
(3) Open TextEdit
(4) CMD+V
You should now have a list of your documents, which you can print etc.

This also works in OS X Finder. You can select files, CMD+C them and then drop their file names into TextEdit by pressing CMD+V.

For it to work with Finder file names, in TextEdit you need to check FORMAT > PLAIN TEXT is chosen, not Rich Text.

Worked like a charm. Thanks.