Problem: CLOSE PROJECT menu item closes whole program, not just current project

This is in regards to Version: Beta (845700) 64-bit - 24 Feb 2020

I have two projects open in Scrivener, the default project, and a project that I imported. I went to FILE->CLOSE PROJECT to close the default project and the whole Scrivener program shut down, not just close the one project and leave the other one open.

If this is expected behavior or else if I’m doing something wrong, please let me know.



Just tried here, does not happend to me. Two projects open, close one, the other is still opened.
but, if I close one after the other, the program closes. The “new project” window should show up, no ? It is not the case.

The “New Project” assistant will show only if you have checked Options > General > “Show start panel when there are no projects open” which is unchecked by default.

Maybe it’s just the way that I got started then. I was in the default environment, from just having installed the program and started it up. Then I wanted to import my old project, from version 1… whatever it is. So that gave me TWO sets of information (manuscript, research, etc, all of it), which looked like two projects being open.

I tried to close / get rid of the default version but it kept closing the program. I couldn’t delete it all either. I just wanted to import my old project so that I could use it in the new program without messing up my current version.

Everything you see in the same Binder is one project. If you import one project into another you still only have one project open.

@jwhitten: Something also very important. Your old Scrivener v1 project gets upgraded to Scrivener v3, project upon opening it with Scrivener v3. A backup of v1 project is ALWAYS created before the upgrade in the same project folder, just in case something with the upgrade does not run as expected. Having a manual backup before the upgrade is also a good idea. There is no need (and is not recommended) to import v1 project into v3 project, if the automatic upgrade runs smoothly for you.

Oh, well maybe that explains the behavior with the meta fields. Let me try doing that and see if it clears up that issue.