problem compiling as novel

I really like scrivener, but I seem to have major problems compiling. If I select Novel format and try to use the standards, I end up with one character on a line. The only way I can get around this is to select compile as is for everything. But I get single-spaced lines and no page numbering.

Wanted to add that I just created a new novel to double-check. Now I can see what is happening.
Keeping all the defaults, by using reveal codes I see that the reason I get one character on a line in WP is scrivener is putting a right margin adjust to 6"" in the file. It appears that the double spacing is there.

So, is this just a problem for me ? Any help would be appreciated.

Am I missing something ?

I also don’t see the Page Settings page in the compile sheet.


Hi Ed,

Have you downloaded beta 026 from the website? That was released about a week after 025 to correct this compile issue and a few other big bugs, so if you haven’t yet, install that and give it a try. Also be sure to read Lee’s post about it, as that contains a note on changes and an extra file to install in order to view PDFs.

Thanks for the quick response. The update fixed the spacing problem, and just in case I downloaded the pdf dll.
Still can’t find where I can get page numbering in the manuscript. Compile doesn’t give the format page option indicated in the help file.
Am I missing something, or is this one last bug ?

Thanks again,

Hi Ed,

Sorry, I missed that in my earlier response. Currently there’s no way to add page numbering, though this will be coming to the compile options. For the time being, you’ll need to open your compiled manuscript in a dedicated word processor and add your numbering, footers, and headers there.

Thanks for the quick answer. It’s no problem adding page numbering after the compile. Looking forward to the final version. As it is, I’m finding scrivener great.