Problem exporting draft in Scrivener

For some reason, I’m now unable to export my draft. I set Scrivener up to export, but the status bar seems to hang about two thirds of the way across. I’m using the latest beta 4.

Same problem as Roger in Beta4. I reverted to b3 and it worked as normal.


I think I’ve narrowed it down to the Export Draft function in Beta4 ‘choking’ on chunks of text more than approximately 3,000 words.

Roger, would that be consistent with your experience of the problem?


It could be. There are a couple of chapters which are over 4,000 words, about two thirds of the way through, which is where it seems to hang. The whole draft is 25,000. I don’t know if I still have a copy of beta 3 to try.

You could try what I did in Beta 4 which is deselect them and then export. If that works, then you could split the files and try to export with them included. It worked in my case. Length of the whole draft seems irrelevant (mine is 133,000). Of course, it’s only a stop-gap measure.


Ive just tried exporting from a copy of beta 3 and that doesn’t seem to work either.

What about deleting the preferences (you might want to keep a copy) and trying again?


Just tried deleting preferences and the problem remains. Also my test using beta 3 was on a different machine.

Please send me a project file that causes the issue (to Beta 4 uses slightly different code for the export - it sounds as though there is a bug in it that can cause hangs in certain circumstances. I can only track it if you send me a project, though - thanks!


I just replicated it twice with your tutorial by copying and pasting in one of the documents until it was over 5,000 words and then over 3,000 words. The export hung both times (earlier in the first case).


Wow, this one is seriously messed up… Please bear with me on this one. I am investigating it, but it is far more oblique than I had expected. Roger, thank you for sending me your project.
All the best,

Please download the update (beta 4.1). I hope I have fixed this, although it was a very strange one and I’m still not sure why the culprit actually caused the problem it did.

You can download the update either by re-downloading beta 4, or right from within Scrivener by going to the Scrivener menu and selecting “Check for Updates” (which will happen automatically when you launch Scrivener next anyway).

Let me know if this fixes the problem for you…

Seems to be working well now. I can’t reproduce the problem in my files or the tutorial. Many thanks, Keith.


Beta 4.1 fixes this for me also.
Thanks a lot Keith for such a fast response.

I can’t find how to download beta 4. I’ve looked everywhere. I searched lit and latte. No results. I’ve searched scrivener. All it says is beta 1.3.

I’m having problems and can’t make it work.


Lyn, this thread is four years old. :slight_smile:

There is no beta 4 for Scrivener anymore. That one has been refined, released, developed, refined, expanded, and then upgraded to 2.0 since then.

I presume you are using Windows, and if that is the case, beta 1.3 is the latest official release.