Problem inserting images in text


I’m completely new to Scrivener and trying it out as I consider buying one. I’m working on a non-fiction project which includes documents with inline pictures. I have tried inserting pictures into the text in different ways as described in the user manual. However, some troubles show up:

When I try to insert a picture (regardless of which way I attempt to do it), no picture shows up on the page. Initially, I place the cursor on an empty line where I want the picture to occur, and use one of the methods - t.ext. Ctrl+G, Ctrl+J. A dialog is shown where I can select the picture. I select it (in my case it is a .png picture), and confirm.

After the dialog has returned to the document, after a short moment, it looks like a line below the cursor in the editor is deleted. The curser disappears, and a tiny flashing dot appears where the picture is supposed to be.

Has anyone a clue to what can be wrong?

Thanks in advance.

Convert the images to jpg

Thanks for the suggestion. I don’t think this is the issue; from the “Open” dialogue, I can see that the program should be able to accept different graphics formats - among others .png.

Besides, I have tried again today, and for some peculiar reason, some .png images now show up when I import them. However, some other pictures do not.

It should be said that all pictures have been produced in the exact same way - from a vector drawing in Adobe Illustrator CC they’ve been exported to .png format - all having the same size. So I have no idea about why some of the pictures show up correctly, while some others don’t.

Anyone having the same experience?

Thanks in advance.

Have you tested with jpg:s? If they behave as expected and png:s don’t (you’re not the first to report problems with png files) I do think that is the issue. If you don’t want to test it, well…


I indeed have tested it with .jpg - same results. However, I found a workaround (not ideal, but it seems to work for both .png and .jpg). I insert one picture as soon as the document has been opened - it works; however, all subsequent insertions fail. I have to restart the application, insert the next picture, restart, etc., until all pictures I want in the document have been placed.

Seems like a bug in the application.

Best regards.


Caveats: I’m new and I’m working on a Mac. That being said, I’ve been reading up on placeholder tags, and thought they should (?) translated cross-platform. Worth a shot, anyway.

Drag your image into your research file. Name it whatever you want - don’t worry about .jpg or .png. I named my file orchidpine.

Hop in to where you want your image to be and type


I snagged that from this article: … -headings/
and I’ve been playing with it with images throughout the book.

Fingers crossed it works for Windows as well!

1 Like

Windows platform
I have difficulties when inserting images into table. Some images (jpg) go well, others not. Near square images went well but wide or high not. But even repeating actions make different results
Another problem; when I hide the borders of the table(pix=0), the table dissapear well but next session I could’t make the borders visible (table menu doesn’t affect borders)