Problem running newly downloaded program

Hi, everyone. I’m frustrated. Earlier today, I downloaded Scrivener to my iBook and read through the tutorial. All was well. I took the iBook home, came back to the office, and decided to download it at work, too, to keep exploring the features. Disaster! I can’t get anything to work on this desktop machine. And now I’m worried about using it on the iBook, in case the same thing starts happening there.

I think my work problems started because I didn’t install immediately. Then I accidentally ejected Scrivener (or whatever the technical term for that is) when I meant to eject something else. I tried to restore it from the trash, but that wouldn’t work, so I deleted all the files, including the preferences, and downloaded it again.

Everything downloaded and installed okay, but when I tried to open the tutorial, it told me that it couldn’t work with a read only file. Then I tried to create a new file, but the create dialogue box wouldn’t disappear, and when I clicked create again, it told me the file already existed. So I opened that file, only to find that I can’t do anything except open the keywords black box. Everything else is grayed out, and clicking on the plus sign does nothing. When I tried opening the tutorial again, it just ignored me and did nothing.

I tried to import a Word document. It seemed to be working, but the copy never showed up. So I basically have a dead program with a lot of pulldown menus.

I deleted everything AGAIN and reinstalled, but the same thing happened. Now I wish I’d never even tried it with the work machine. I was happy about the software on my iBook this morning. Now I’m stressed about it – and obviously I can never use it at work unless this situation improves. (My office machine is a Mac PowerPC G5 running OS X Version 10.4.2.)

Any suggestions? Right now, I’ve deleted everything again and emptied the trash. There isn’t a single .scriv file left on my machine, but I’m not sure that’s enough. Maybe I should’ve uninstalled in a different way.

Any advice on how to start over and make it work would be much appreciated. (I also need to get over my case of nerves so I can use the one on the iBook with confidence. Assuming I can create a new file there, since I haven’t tried yet. But at least the tutorial worked on that machine.)

Thanks!

This sounds very much like two different problems:

  1. The error saying that Scrivener cannot open a read-only file: as it says in the readme.rtf file, you cannot open the tutorial directly from the DMG. You must drag it onto your hard drive and open it from there.

  2. The problem whereby the New Project dialogue does not disappear and you cannot get any projects to open. This is usually a fonts problem. Launch Scrivener and then go to Scrivener > Preferences… Under the Fonts & Colors pane, check that all of the fonts pop-up buttons are populated with fonts that are active on your system. If any are blank, this almost certainly your problem. One other user had exactly the same problem because he had disabled some standard system fonts.

Let me know if this fixes your issues.

Best regards,
Keith

Thanks for the prompt answer, Keith!

I thought I was trying to open the tutorial that I’d copied onto my hard drive, but I guess I must have accessed the wrong one.

The second part of your answer is very, very telling. Fonts… Fonts are the bane of my existence here at work! We use Extensis Suitcase through our server, and I have very little control over the fonts that are active on my machine. Frankly, I’m not even sure what they are from day to day because there’s a lot of behind-the-scenes maintenance happening. Last week, I couldn’t even display the default Word fonts properly because they weren’t activated. Talk about a lot of error messages…

As long as I haven’t done any damage with all my downloading and deleting, I’ll download the program again next week and play around with the fonts some. I’m sure that’s exactly what the problem is, given my ongoing battles here at work. (Fortunately, my laptop is immune to all that!)

Thanks again!

First, let me say that Scrivener is working like a dream on my iBook. I’m still on the trial period right now, but I’ve created several binders and definitely plan to buy it before the month is up.

My office computer is a different matter, though. I just downloaded the software again (third time, after carefully deleting all parts from each previous download that didn’t work including the preferences file), and again, when I tried to create a new file, the “create” dialog box wouldn’t disappear. If I click “create” again, it tells me the file has already been created.

So I went in and opened that blank binder from recent projects. Again, hitting plus did nothing but make the plus sign blink. So I went into preferences and changed everything to Geneva, the font I use in Word all the time here. All the fonts were visible in the menus, though, including the default one. I saved my preferences, and still I could do nothing. Then I tried opening the tutorial – carefully saved onto my hard drive this time – and it gave me another blank binder. So now I have two blank binders open – both labeled just “Window,” not the actual binder name – and I can’t do a thing with them except open a blank keywords box (well, the unnamed tutorial has its ready-made keywords, I just noticed) and make changes to the preferences panel.

I guess I just need to resign myself to using the software exclusively at home. This situation does put an unease in my mind, though, that someday I might upgrade my system or do some other upgrade on the iBook and find that I can’t get back into the working files. And that could be disastrous!

Any other suggestions for waking up the software at work would be much appreciated. I’ll just close the program for now and leave it in my applications folder, as downloading it anew doesn’t seem to improve anything.

Thanks! And again, I’m really loving the software at home. I anticipate getting rid of a lot of paper clutter as I type my notes into my various Scrivener binders. Very liberating!

Hmm… Strange. The problem you are reporting - where the window is blank except for saying “window” - is definitely related to the Fonts problem. So it would seem that there are still font problems involved, although I’m not quite sure how to suggest to resolve them given that it is a work computer involved…

To address the concern of application malfunction due to font failure: The good news is that there are certain things you can do to your system to fix the problem. Wiping out font caches and checking for corrupted fonts generally fixes all problems. In worst case scenarios I’ve had to move system fonts from a clean system to fix a messed up system. In any case, once the problem is rectified, the applications should work nicely. Depending upon the severity of the font malfunction, the entire system itself can collapse. Since it is a work computer, you may or may not have system level access; if you do not, there is probably an IT professional who can service your system and get it functioning again. But to reiterate, your data is safe, and once the problem is solved, you can get right back to it.

Since this problem has come up four times now on the boards, I’m going to be putting in a troubleshooting section that describes the symptoms, and a few tips for fixing font problems, into the next edition of the FAQ.

Oh, how I hate font issues… I work for a magazine, and half of our deadline cycle this month was taken up with artists and the production manager installing and uninstalling fonts in my machine via Extensis Suitcase. Corrupt fonts, duplicate fonts, screen fonts, system fonts… Right now, the machine is functioning beautifully (no more error dialog boxes!) except for my Scrivener problem, so I don’t want to rock the boat and ask for more adjustments right now. Those will probably be coming as soon as I’m working with layouts in Quark again anyway.

Since I’m on a server and working with Quark files shared with several artists, it’s best if I just leave everything up to our system administrator, instead of tweaking the machine for one program that I might or might not use for work-related projects anyway… (I really had thought of a great use of it for my upcoming stylebook update, but… oh well.)

I’ll just keep the software in my attachments folder and test it out now and then as future adjustments are made. Maybe I’ll stumble onto the right combination of fonts at some point. For now, though, I’m just happy for the simplicity of my iBook fonts, which love to get along with Scrivener.