Problem: Scriv compiling as sections instead of chapters

I’ve been working with Scrivener for years, love the program to bits. But with my new project, I’ve come across a new-to-me problem, and I can’t seem to solve it no matter what I try. When I compile, each new chapter comes up as a new section in Word, complete with a brand new page 1 each time. Needless to say, this won’t work for a novel!

My settings are pretty normal: manuscript, compiling to RTF or Word doc. I’ve switched to novel but, unsurprisingly, it makes no difference.

I’ve tried deleting the chapter folders and replacing them. I’ve tried looking at the section layout in the formatting pane, and I don’t see any unusual markup to explain this. It’s not about having “page break before” checked or unchecked. I assume there’s a setting somewhere that tells the compiler that the chapter folder starts a new section with restarted pagination, but I can’t figure out where (or how it snuck in there!).

Any help would be greatly appreciated!

Have you looked at the Separators pane?

Have you compiled to any of the e-book formats? E-books use section breaks between chapters (to generat e the Table of Contents entry), and it’s possible that you have a stray setting from that.


Thanks for the reply!

I’ve looked at the Separators pane. Folder separator and text/folder separators are page breaks, but I’m not seeing extra blank pages in my Word doc, but rather, new sections, so that’s not it.

I’ve never compiled to any ebook format. If this was the issue, though, where would the stray setting live? (IOW, how could I track it down?) It also brings up a question: when you compile to an ebook format, how does it know to continue pagination across sections and not restart paginating at page 1 each time? Maybe therein lies the answer to my problem.

Also, my husband thinks the project might have gotten corrupted somehow, and this is the result. Could this be the case? Or is it more likely that there’s a setting or bit of markup somewhere that’s causing this?


Please try changing the separators to empty lines. If that compiles without the section breaks, try changing back to page breaks and see if the problem reoccurs.

Also, look in Compile -> Page Settings pane and make sure that you’re using the standard <$p> placeholder for the page number. If you had accidentally told the project to restart pagination, this is where the command would be.

I don’t think we’re dealing with a corruption problem, but it’s easy enough to check:

  • Make a backup of the project, using either File -> Backup -> Backup To or -> Backup Now.

  • Find the project in Finder. Right-click on it, and select the option to Show Package Contents.

  • Navigate to the Settings subdirectory, open it, and look for the compile.plist file. Drag that file out to your desktop.

  • Open the project in Scrivener and see how it behaves.